Jump to content
Sign in to follow this  
skyrocket

Magazine Mode: How can I make pagelines use "thumbnail" sized clip images (without CSS scaling)

Recommended Posts

skyrocket    1
skyrocket

I just changed my layout to magazine mode. Unlike the full width mode, pagelines calls the full size featured images for the clips and scales them down via CSS. The impact on page load is huge since the frontpage has to load about 50 images with a size of 600x400 px on average. I can't decrease the size of the featured images per se because I'm using them inside my posts. Is there an easy way to add a function to functions.php and make pagelines pick "thumbnail" size clip images (or any other size)? Note: I tried the solution shown in this thread, http://www.pagelines.com/forum/discussion/19613/post-clips-size/p1 , but it screwed up some plugins that are using an even smaller thumbnail size. So I need a solution that really is specific to the clip images. Any help would be very much appreciated!

Share this post


Link to post
Share on other sites
skyrocket    1
skyrocket

Thanks for this. I'm not good at PHP. I'm imagining that targeting clip images specifically is a pagelines customization. Not a general wordpress thing. Do you know how I can do that?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi, OK, firstly you have posted in the incorrect forum, so I have moved your post to the PageLines Framework forum instead of PlatformPro's. I have visited your website and found that you're using the option "On Top" for clip. The "On Top" has been designed to use the full width image and not the thumbnail. There was a similar topic a few weeks back and if you add the code below, it should resolve your issue.

add_filter( 'post_thumbnail_size', 'my_post_image_size' ); function my_post_image_size( $size ) {
	    if ( is_single() )
	        return $size;
	    else
	        return 'medium';
	}

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
skyrocket    1
skyrocket

I think you must have been very busy correcting and pointing out my mistake of posting this question to the wrong forum because you obviously haven't read my question. I already mentioned above that the solution you posted just now doesn't work for me. I also explained why it doesn't work.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Which plugins are effected by the code above, so I can test this on my end.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
skyrocket    1
skyrocket

I found a solution for this problem that works pretty good. Instead of changing the pagelines source I just did this to achieve the same result: 1) Switched from "image on top" to "image left aligned" in magazine mode 2) Added this CSS code

.clip_box .post-meta a { width: 100% !important; }
Works perfectly. Problem solved. PS: The plugins that interfered were "Wordpress.com Popular Posts" and "Smooth Slider".

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, thats a cool little CSS snippet, thanks for sharing.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×