Jump to content
davemoppert

Buddypress style issues

Recommended Posts

davemoppert    6
davemoppert

I updated the Buddypress plugin from the pagelines store and now the styles are all out of whack. All the buddypress pages span the full width of the browser for some reason. Also, the buddypress options have disappeared in the pagelines settings. I can't figure out where to set up the buddypress pages in the pagelines settings. The base theme is activated, and the buddypress template pack plugin is installed. When I go to Appearance > BP Compatibility and click on reset, after I save it, I get an message that says: "You'll need to activate a BuddyPress-compatible theme to take advantage of all of BuddyPress's features. We've bundled a default theme, but you can always install some other compatible themes or update your existing WordPress theme." Did I do something wrong? Is there something new about the latest Buddypress plugin in the Pagelines store?

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

I messed with the CSS to try and fix it... It is (kinda) working, but doesn't feel like the best solution... Isn't buddypress supposed to be in the .content-pad div?? cause it's not. .buddypress-page #dynamic-content { width: 940px; margin: 0 auto; } .buddypress-page #content { min-height: 500px; padding: 0px; width: 620px; float: left; }

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi, I have just installed the latest BuddyPress, PageLines Framework and Wordpress and see no issue. Therefore, can you provide screenshots and links to where you're seeing these issues please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

I commented out the custom styles to the CSS so you can see what Is going on. http://www.skypark.tv/activity/ The buddypress content spans the full width of the browser. I want it the buddypress content to only span the width of the content area. I also would like the page to include the sidebar on both sides of the content (or at least reflect the page layout mode chosen for each buddypress page)... I need some sidebar widgets to display on the buddypress pages, but for some reason it shows up underneath the content (most likely because the content spans the full width).

Share this post


Link to post
Share on other sites
Rob    547
Rob

Dave, you may have to run the BP Compatibility thing again to update BuddyPress and the theme together. Have you tried that?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

I updated buddypress pagelines plugin. After I did that, it broke the styles. After it broke the style, I reset the settings (multiple times) in the BP Compatibility plugin, but it did not help... Is there a step I am missing?

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Nothing is working... :( Please help.

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

All the Buddypress page options are not there either. Before there were default page options for buddy press. Now there isnt.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Dave, Are you using any cache plugin ? Can you disable all other plugins except for PageLines plugins and BuddyPress and see if this resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

No. In fact, I deactivated all of the plugins and reset multiple times as well. It seems like the BUDDYPRESS pages do not follow the same page structure as Pagelines (But I thought that is what the Pagelines Buddypress plugin was supposed to fix)... I can offer login credentials if someone would be kind enough to look at the site.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Dave, Like I mentioned in my previous post, I have installed BuddyPress and everything is working as intended. Therefore, can you disable all non-PageLines plugins and then enable the PageLines debug mode please. You can do this by logging into your Wordpress Admin Dashboard > PageLines > Site Options > Advanced > PageLines debug. Once you have completed the above, can you reply here please, informing us.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Hi Danny, I deactivated all of the plugins (except for buddypress) that are not Pagelines plugins. The only plugins activated are: BuddyPress BuddyPress for Pagelines BuddyPress Template Pack Pagelines Customize Pagelines Sections I activated the debug as requested. I also reset the Buddypress Template Pack again for good measure - but nothing changed :( Thanks for your help!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Dave, shoot me a message via the Inbox at the top of this page with admin login credentials. I'll take a look.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Any updates on this? I gotta get Buddypress fixed...

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Dave,

Did you send Rob a PM at all ?

If so, can you send him another one as we have just switch forums.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Yes I did. He responded a week ago letting me know he'd look into it. Have not heard anything. Any new developments? Need help.

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Please help! The Pagelines Buddypress plugin does not seem to do anything... :/

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Let me re-iterate the issue:

I have buddypress installed on my Pagelines site BUT Buddypress pages are not displaying properly.

The buddypress content spans the full width of the browser. I want it the buddypress content to only span the width of the content area. I also would like the page to include the sidebar on

both sides of the content (or at least reflect the page layout mode chosen for each buddypress page)... I need some sidebar widgets to display on the buddypress pages, but for some reason it shows up underneath the content (most likely because the content spans the full width).

You can see what I am talking about here: http://www.skypark.tv/activity/

The page should have a sidebar on the left, the buddypress content, and another sidebar on the right.

I installed the buddypress compatibility plugin and ran the setup on it (multiple times) - still I get an error message stating: "You'll need to activate a BuddyPress-compatible theme to take advantage of all of BuddyPress's features. We've bundled a default theme, but you can always install some other compatible themes or update your existing WordPress theme.".

I also installed the Budddypress for Pagelines plugin from the Pagelines store. After installing this plugin, nothing changed... I do not even see any additional settings - not really sure what this plugin does.

The wordpress installation is up to date. The pagelines theme is up to date. The buddypress plugin is up to date. The buddypress compatibility plugin is up to date. The Buddypress for pagelines plugin is up to date.

I am at a loss... I have deactivated all other plugins to troubleshoot... didn't help. Rob has looked into this issue for me and said that I have done nothing wrong with the installation, and that he is working on it, but I have not heard anything from him in a while.

I can offer login credentials for anyone who thinks they can help...

Share this post


Link to post
Share on other sites
meilena    8
meilena

Hi Dave,

I am also checking on this for you to see what we can do, hopefully I will hear something soon and can give you an update. Thanks so much for your patience :D


Meilena Hauslendale

PageLines.com

"A Better Way to Build Websites"

Share this post


Link to post
Share on other sites
Simon    247
Simon

I just installed buddypress, and a child theme, the template pack and its all working properly all layouts.

Actually the CSS looks better without the pagelines-buddypress plugin.

So have you tried without that activated?

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

I deactivated the pagelines buddypress plugin, but am still having this issue with the buddypress pages spanning the full width of the browser. Here are my page layout settings:

Screen-Shot-2012-10-01-at-9.11.34-PM.png

The buddypress content spans the full width of the browser BUT I want it the buddypress content to only span the width of the content area (like the rest of the pages on the website). The reason I need the buddypress pages to work inside the pagelines content area is because I need to include the sidebar on both sides of the content (or at least reflect the page layout mode chosen for each buddypress page)... I need some sidebar widgets to display on the buddypress pages, but for some reason it shows up underneath the content (most likely because the content spans the full width).

My best guess is buddypress content does not reside in the content area OR the styles conflict somehow in the CSS.

Here is what the buddypress pages look like:

Screen-Shot-2012-10-01-at-9.17.36-PM.png

Please help.

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

I basically want the buddypress pages to respond to the page layout:

Screen-Shot-2012-10-01-at-9.25.15-PM.png

So the buddypress content should respond to the chosen option and will display in the grey area (content area)

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

I have just gone to my test installation, clicked on my Activity page and then scrolled down to the PageLines Meta settings and changed the layout several times. Each time the Activity page changed it layout to the layout I chose.

http://d.pr/i/egYj

http://d.pr/i/7T0X

http://d.pr/i/RaTt

Therefore, make sure you have both BuddyPress, PageLines/BuddyPress and the BuddyPress template pack installed and up to date.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Thanks Danny... I am gonna start over-- Fresh wordpress install, fresh pagelines install, fresh buddypress install... I will keep you updated on how it goes.

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Started from scratch. Everything works fine now. Not sure what the problem was but sure glad its not happening anymore.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×