Jump to content
Sign in to follow this  
leowu

Boxes Section Custom CSS class

Recommended Posts

leowu

I created a css class with the following code

	.homepageboxset {
	    border: 0px solid #FFFFFF;
	    padding: 10px 0 0 0;
	    text-shadow: 0 0px 0 #FFFFFF;
	}
	

Then, I tried to apply this class to a set of boxes secton on the homepage like this: pagelinesboxescss.pngby adding .homepageboxset to the "Custom CSS class" section on Boxes Section meta setting page. But it doesn't work. What did I do wrong?

Share this post


Link to post
Share on other sites
Danny

Hi, Don't use the . at the beginning, simply add homepageboxset and nothing else. That should resolve your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
leowu

Danny, thanks for the reply. I remove the dot, still doesn't work. You don't mean the dot (.) in the code, do you? I used the following code in my Pageline Setting --> Custom Code --> Custom CSS

#page #boxes .box-media-pad{
	    border: 0px solid #FFFFFF;
	    padding: 10px 0 0 0;
	    text-shadow: 0 0px 0 #FFFFFF;
	}
But this apply this rule to all the boxes section. I only want to apply it to a few sepecific sets. So I used
.homepageboxset {
	    border: 0px solid #FFFFFF;
	    padding: 10px 0 0 0;
	    text-shadow: 0 0px 0 #FFFFFF;
	}

and I use homepageboxset as custom css rules for those sets. But it doesn't work. Any ideas?

Share this post


Link to post
Share on other sites
catrina

No, he meant the dot in the CSS class box, not in the code itself. Instead of homepageboxset, try this:

plgrid.homepageboxset


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
leowu

Hi Catrina, plgrid.homepageboxset didn't work neither. Any other ideas?

Share this post


Link to post
Share on other sites
Rob

Inside the place where you added the class, you incorrectly placed a " . " in front of the word hompeageboxset. You do not add punctuation except for - or _ to any class you create as it will cause the element to fail or potentially can crash your CSS.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
leowu

@rangelone Thanks. Do you mean in my code or in my setting? I tried both with the dot and with out the dot in my setting, neither worked. I have no idea why. Please help.

Share this post


Link to post
Share on other sites
Danny

Hello, When to create/edit a box, you have the option to add a custom class to this box. When adding a class, do not add a dot before the class name, only use the class name. The dot gets added automatically. http://screencast.com/t/KYc47vr08z So in the class box only add this without quotes "homepageboxset" but when you add the custom CSS for this to Custom Code > CSS Rules, you must have a dot at the beginning.

.homepageboxset {
	    border: 0px solid #FFFFFF;
	    padding: 10px 0 0 0;
	    text-shadow: 0 0px 0 #FFFFFF;
	}


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
leowu

@Danny Thanks. That's exactly what I did, but didn't work. I am using iBlogPro5. Is it possible iBlogPro5 doesn't support this feature?

Share this post


Link to post
Share on other sites
Danny

Hi, I have just this moment tested this and it works fine for me. All I did was add a custom class to the Boxes custom class field, like you can see below in the image. http://screencast.com/t/l26JAwaSiwq Then all I did was go to Custom Code > CSS Rules and add the following:

.test12345 { background:black; }

It give this box a black background. So if this isn't working for you, can you explain in detail the steps you took please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
leowu

Hi @Danny, I tried your method on the PageLines Platform, it worked perfectly. However, when I switched the theme to iBlogPro5, only the background of the boxes section became black, as shown in the image below. pagelinesboxesblackbackground.png Please help. Thanks.

Share this post


Link to post
Share on other sites
catrina

Can you please provide a link to your site with iBlogPro5 enabled? I think I have the wrong site.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×