Jump to content
Sign in to follow this  
mjm5350

Missing H1 tags on posts

Recommended Posts

mjm5350

Please bear with me. I'm not a programmer...On other themes I have used, the post title shows up as H1 tags in the code I just created this site using platform pro and cannot seem to find the H1 tags on any of my posts. Obviously concerned about SEO. I have tried clicking show post titles and unclicking show post titles box. What am I missing? I'm sure it's something simple...I don't think I have any hair left to pull out! I would be fine adding the H1 manually inside each post, if there were a way to not show the post title on each post so they would not be duplicated for the reader. Also, on my articles page that I am using to show excerpts of my posts the more footer items will not disappear even with I click the toggle boxes inside the post. On all other posts and pages they do no show when the boxes are ticked. Thank you in advance. Mark

Share this post


Link to post
Share on other sites
catrina

By default the entry titles inside posts use

headings. I know adding

manually would be a hassle, but there is a way to hide post titles if you're willing to add the headings that way. As for the more footer items, what are you referring to specifically? The social sharing icons inside the individual posts?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
mjm5350

Catrina, thank you for your response. Maybe I don't understand the process??? I thought the post title would by default become H1 and I would create any additional headings H2, H3 etc.manually inside of the post. This is how I have done on previous themes. As I understand the relevance for SEO, H1 is the most important heading so if I have to add manually, I will. It sounds like if I could just hide the post title as you mention and add H1 manually I would be fine. So how do I keep the post title from showing or is there a better solution? on the more footer, please see http://woodtoolsmagazine.com/articles to see the 3 columns and twitter section at the bottom of the page, just above the footer. I have clicked to not show inside of page but the section still shows. This is the only page that shows this info. The toggle clicks to turn off on other posts and pages has removed this info. Thank you again for your help. Mark

Share this post


Link to post
Share on other sites
catrina

In the PageLines code the entry titles use the

heading (although I'm not sure why this is). Are you looking to hide the default entry titles in both the main blog page and single post pages? Also, you have this articles page set up as the posts page in Settings > Reading, yes?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
mjm5350

I dont care so much about SEO for main blog page, but would prefer titles to show. On single posts all I want to do is have H1 show up in the code for SEO purposes when I write a new post. Regarding article page set up. Yes, I have it set up that way so the page will show up in the main menu and reader can see excerpts.

Share this post


Link to post
Share on other sites
catrina

Please add the following code to Custom Code > Custom CSS to hide the post titles in single post pages:

body.single div.post-title.fix h2 {display: none !important;}

Can you please take a screenshot of the template settings for your blog page and post it here?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
mjm5350

Catrina: To insert the code go to appearance then editor? Where specifically do I then insert the code? Under the stylesheet css or under single post (single.php) Please realize my coding knowledge is minimum. I need to get this fixed first. I'll come back to the more foot info later. Thank you for your help Mark

Share this post


Link to post
Share on other sites
mjm5350

I inserted into options, custom code>custom CSS like you describe. However, nothing has changed. I inserted the code between the body that that was already there it now looks like this body{body.single div.post-title.fix h2 {display: none !important;}} I presume I need to delete maybe the first body or last } Thank you. Mark

Share this post


Link to post
Share on other sites
Rob

Mark, that's incorrect coding.

body.single div.post-title.fix h2 {display: none !important;}

is a separate line. body {} should be first and remained basically unchanged. Please correct it as the code you have will corrupt your site.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
mjm5350

Heres what I posted. body{} body.single div.post-title.fix h2 {display: none !important;} The post titles are still showing. What am I missing?

Share this post


Link to post
Share on other sites
mjm5350

heres what I have body{} body.single div.post-title h2 {display: none !important;} no change, post titles still show

Share this post


Link to post
Share on other sites
Jenny

I don't see any custom code added on your site in your site's CSS. Maybe you have deleted it? Visit PlatformPro -> Custom Code -> Custom CSS.. completely remove the line that says

body{}
Remove the line that says
body.single div.post-title h2 {display: none !important;}
And add this
.single .post-title h2 {
	    display: none;
	}


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
mjm5350

If something was deleted, it was not on purpose... Went to - Custom code- custom css - css rules box and inserted and saved .single .post-title h2 { display: none; } no change...

Share this post


Link to post
Share on other sites
catrina

Try:

div.post-title-section.fix div.post-title.fix h2 {display: none !important;}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Rob

Since we're unlikely to update PlatformPro, you could create a modification or change the sections so that the titles you're concerned about are hard coded to H1 instead of H2. You'll need to find the code. I have no clue where it is. It should be in a section, which you can simply copy (folder and all) to the PlatformBase child theme folder.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×