Jump to content
Sign in to follow this  
conceptaustralia

Permalinks affecting the PageLines layout!

Recommended Posts

conceptaustralia

Hi, I have just started building a new site and wanted to change the permalink setting to show a nicer link rather than the jargon that comes up. Doing this has now affected the layout of the pagelines template so I changed back to the twenty eleven template and it works without any issue so now I am asking what is reason the template is not working correctly. There is no .htaccess file and I note that when changing the settings in the permalinks area it stated it couldn't modify the file ad asked that I modify it. Went on the FTP through Filezilla and turned on hidden files and did a search of the site but there was no .htaccess file there for me to edit; when I made a file for it and changed the access to it at 777 just for a test the whole wordpress site goes down and gives a generic 500 error. Would really appreciate some help on this as it seems odd that the default templates still work without a hitch but the pagelines template doesn't. Thanks in advance :-)

Share this post


Link to post
Share on other sites
Simon

Add this to wp-config.php define( 'PL_NO_DYNAMIC_URL', true );

  • Like 1

Share this post


Link to post
Share on other sites
conceptaustralia

Hi Simon, I did see that in another post and it did fix the layout up on the home page but then when I went to click on any link it does this: Not Found The requested URL /wordpress/used-caravans/ was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. Any ideas on this? Thanks

Share this post


Link to post
Share on other sites
Rob

Go to Dashboard > Settings > Permalinks. CHANGE NOTHING! Just save the settings. The Permalinks aren't saved.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
conceptaustralia

I have just done what you said and it hasn't made a change. It does still ask to modify the .htaccess file that I can't see on the server at all so is this causing the problem.

Share this post


Link to post
Share on other sites
conceptaustralia

At the moment so I can keep working on the site I have changed the permalinks back to default and removed the define( 'PL_NO_DYNAMIC_URL', true ); line from the wp-config file. Thanks for your help and hope to get to the bottom of this.

Share this post


Link to post
Share on other sites
Danny

Hi, Would it be possible for you to add the line of code again and change your permalink structure again. So we can investigate your issue please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
conceptaustralia

Hi Danny, Sorry for delay. I have changed the permalink structure and have uploaded the line of code as requested. Still can't help thinking it is a issue with this .htaccess file that I can't find but when I make one with the code wordpress says to put in causes the whole site to go offline.

Share this post


Link to post
Share on other sites
Danny

Hi, If there is no .htaccess file and when you create one, your site goes offline, I think you will need to ask this question on the Wordpress support forums or contact your host.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon

The reason you cant find the .htaccess file, is any 'dot' file on a unix server is invisible by default. So try looking in your ftp client for a setting to show hidden/invisible files, and if you still cant see it, then you need to create the file .htaccess

Share this post


Link to post
Share on other sites
conceptaustralia

Got it working finally... thanks for the help if got me going in the right direction... :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×