Jump to content
Sign in to follow this  
glassbrige

Google Maps Shortcode issue

Recommended Posts

glassbrige

Hey Guys, I am attempting to have a map of Australia as a media feature in WhiteHousePro. When attempting to use the Google Maps shortcode, I get the following image when I use this shortcode:

[googlemap width="610" height="340" address="Australia"]
oiAes.png When I attempt to use a simple iframe to embed, I get the exact same issue. Google Maps Embed Code:
<iframe width="610" height="340" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=australia&sll=37.0625,-95.677068&sspn=55.016555,135.263672&ie=UTF8&hq=&hnear=Australia&ll=-26.273714,132.363281&spn=52.132463,107.226562&z=3&output=embed"></iframe><small>View Larger Map</small>[/code]

If two maps are on the feature page as separate features, only one works. Browsers Tested: Google Chrome Mozilla Firefox Internet Explorer Any ideas?

Share this post


Link to post
Share on other sites
Andrew

Sure, did you try a more specific address? I think Google tries to nail things down to a specific point.

Share this post


Link to post
Share on other sites
lglass858

I am having a similar problem. Even with a specific address the bottom right corner of the google map is shown. With many addresses the actual marker and address does not fall into the bottom right corner. Does anyone know of a shortcode that would center the map shown?

Share this post


Link to post
Share on other sites
bryan-hadaway

@Alistair - Still having troubles after Andrew's suggestion? @Lisa - Can I please get the link to your website? Thanks, Bryan

Share this post


Link to post
Share on other sites
glassbrige

Yes I continued to have issues, so I removed the shortcode and used a static image generated by Google instead. The unreliability of the shortcode had to be resolved immediately as we were planning on going live. staticmap?center=Australia&zoom=3&size=610x340&sensor=falsehttp://maps.google.com/maps/api/staticmap?center=Australia&zoom=3&size=610x340&sensor=false See the following link for more information about static Google Maps: http://code.google.com/apis/maps/documentation/staticmaps/ Interestingly enough, when I copied and pasted the above iframe in my original post into a simple text file, it worked just fine. *Something* in the template is interfering, and I haven't the time to work it out. I'm thinking that there is a conflicting variable in the google maps JavaScript and the WhiteHousePro JavaScript. With regards to a specific address, that didn't seem to resolve the issue. Alistair

Share this post


Link to post
Share on other sites
pagelinesuser

Make sure that when you enter the shortcode, that you are in HTML mode and not visual mode in the editor. Visual mode adds extra code tags that throw off the googlemap call. After entering the following code in HTML mode, I got it to work ok :) [googlemap width="610" height="340" address="Australia"]

Share this post


Link to post
Share on other sites
tludi

Make sure that when you enter the shortcode, that you are in HTML mode and not visual mode in the editor. Visual mode adds extra code tags that throw off the googlemap call. After entering the following code in HTML mode, I got it to work ok :) [googlemap width="610" height="340" address="Australia"]

Share this post


Link to post
Share on other sites
lglass858

Bryan website link is buddyglasspitching.net

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×