Jump to content
Sign in to follow this  
tpldrew

Shortcodes - Tabs - Default Tab not loading as Active

Recommended Posts

tpldrew

I just love the Shortcodes, gang! Love 'em. I have just one thing I'm trying to fix for a tabbed shortcode on the page highlighted. The active tab doesn't seem to load on default as active. This appears to be the case in the demo as well. Once I've clicked on it, it works fine. Any ideas? Thanks, Drew

[pl_tabtitlesection type="tabs"]
	[pl_tabtitle active="yes" number="1"] You [/pl_tabtitle]
	....
	[pl_tabcontent active="yes" number="1"]
	   Brandscaping is a methodology. One designed to help you embrace the paradigm shifts in the marketplace. Look, we're all being asked to do more, with less. Brandscaping allows you to leverage the assets and audiences of your partners to drive new business in ways you've never considered before. Brandscaping is for business people.
	  [/pl_tabcontent]
	...
	

Share this post


Link to post
Share on other sites
Danny

Hi Drew, Basically, your shortcode is incorrect. You're missing the following: ??? [pl_tabs] at the beginning of the shortcode. ??? You have two tabs labelled as number="1" ??? [/pl_tabs] at the end of the shortcode. I recommend you go to the link below and copy and paste the shortcode from there and work with that. This way there can be no mistakes. http://demo.pagelines.com/framework/tools/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tpldrew

I apologize... I only showed an excerpt of the entire shortcode. It's as you state and correctly input in the platform. Beginning and ending with [pl_tabs] Still, the first tab is not active on load. - drew

Share this post


Link to post
Share on other sites
tpldrew

Hey Danny, I noticed something else. It looks like you can only have one set of Tabs on a page. Is that correct? If I add another set of tabs they both move together. - Drew

Share this post


Link to post
Share on other sites
Rob

For the last issue, try wrapping each set of tabs code in a unique div.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
tpldrew

Ok rangelone. Let me give that a shot. - Separate divs. Any word on the default tabs? Thanks, Drew

Share this post


Link to post
Share on other sites
Danny

Hi Drew, Did you do as I mentioned above, where your tab code was incorrect? Basically, where you have two tabs with the number 1 (See your original post). Therefore, can you post your entire shortcode to http://paste.pagelines.com and the provide a link here. You most likely, still have that error in your tab code.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Oh, simply add at the beginning of your code this:

[pl_raw]
And at the end of your code add this:
[/pl_raw]

So it looks like this: http://paste.pagelines.com/1bu


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tpldrew

@Danny, I tried that. No luck. Still the default tab is not illuminated. - drew

Share this post


Link to post
Share on other sites
tpldrew

Danny, That's how it should look. It doesn't look that way for me. Actually, the entire tab section isn't showing up in Safari while it works in chrome. I may have to dump the tabs soon. - Drew

Share this post


Link to post
Share on other sites
Danny

Hi, Can you provide me with a link to where your tabs are please, so I can take a closer look.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×