Jump to content
Sign in to follow this  
vereggen

Author link showing 404

Recommended Posts

vereggen

When I select the author name on my posts it shows a 404 page not found error. You can check out my test site here http://rapidsuccessstrategies.com I have a basic install of wordpress / pagelines / iblogpro (using latest versions of all three). Does pagelines support the author link?

Share this post


Link to post
Share on other sites
Rob

It does. Do you have your author pages set up via Dashboard > PageLines > Page Options > Author Posts?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
vereggen

Yes ... I can see the set up via Dashboard > PageLines > Page Options > Author Posts However there is not an option to enable / disable? I tried hiding a couple of the sections within the page options for author posts (i.e. hide branding) however the option was not saved after I pressed save options. After a bit more playing around I cannot save options for the following ... - Tag Listing - Author Posts - 404 Page The other page options work fine (settings stick after I save). There seems to be a problem with saving these options ... would that be the reason that the author link doesn't work?

Share this post


Link to post
Share on other sites
Danny

Hi, Just so we can rule it out can you disable all active plugins and see if this resolves the issue. If the issue persists after the disable of your plugins. Please reply here and we can investigate this further.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vereggen

Disabling all plugins does not resolve this issue.

Share this post


Link to post
Share on other sites
vereggen

A few more points ... 1) As a test I just did a fresh install of wordpress 3.4.1 / pagelines 2.2.5 / iblogpro 5.1.3 and the author links work on my hosting domain - this is a good sign 2) At first I thought the problem might have occurred when I upgraded my test site http://www.rapidsuccessstrategies.com site the site from wordpress 3.3.2 / pagelines 2.1.6 / iblogpro 5.1.1 However on my main site http://www.rapidsuccesscoach.com which still uses wordpress 3.3.2 / pagelines 2.1.6 / iblogpro 5.1.1 I get different behaviour ... a) the author links do not work - which leads me to believe that it was not upgrading that caused the problem - it was there before I upgraded B) the difference is that I CAN save options for the author posts - the options stick after I save - which is different after the upgrade c) I CAN also save options for tag listing - the options stick after I save - which is different after the upgrade d) I cannot save options for 404 page - the options do not stick after save - this is the same behaviour as prior to upgrading 3) Based on this my conclusion is that this was a problem was there with the initial intall of wordpress 3.3.2 / pagelines 2.1.6 / iblogpro 5.1.1 The big question now ... how can I get it to work now on both my my test site (after upgrade) and my main site (prior to upgrade)?

Share this post


Link to post
Share on other sites
vereggen

After some more playing around ... 4) On the fresh install site http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com I can NOT save options for Tag Listing / Author Posts / 404 Page - This is the same behaviour as my upgraded test site http://rapidsuccessstrategies.com The funny 'save not sticking' behaviour is consistent between upgraded / fresh install 5) On the fresh install site http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com when I change permalinks from default to /%postname%/ the author links I get the 404 error - THIS EXPLAINS THE ORIGINAL PROBLEM There appears to be a bug somewhere when you use permalinks set to /%postname%/ 6) On the fresh install site http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com I disabled iblogpro theme and just used the pagelines framework and I STILL get the 404 error from author links with permalinks changed to /%postname%/ 7) On the fresh install site http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com'>http://rapidsuccesshabits.com I disabled pagelines framework and the author links NOW WORK with permalinks changed to /%postname%/ So this appears to be a bug in the pagelines framework with author links not working when using permalinks to /%postname%/

Share this post


Link to post
Share on other sites
Danny

Hi, This is difficult as I am unable to reproduce your error. I have just tested on two different sites and was still unable to get any issue with the author pages. I was only using /%postname%/ http://screencast.com/t/IIewOV5Bayaf Are you sure that you have disabled all active plugins and any removed any custom code you may have added ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vereggen

Dan ... thanks for looking at this. Yes ... everything is disabled / no active plugins / no custom code ... this is the fresh install I just did last night. I noticed that you just have first name as the author and that I have first and last ... so I dug a little deeper a) the html code that appears when I disable pagelines frameworks ...

Ron Vereggen[/code]

	
	 the html code that appears when I enable the pageline frameworks ...
	
	

There is a space between the first and last name with pageline frameworks c) I created a test user on my system with just a first name ... http://rapidsuccesshabits.com/author/test/ ... the author link worked It looks like the space in the name is the problem.

Share this post


Link to post
Share on other sites
Danny

AH! nice catch. However, I have just created a new user John Doe and I still have no issue, I click his name and it goes to his author page.


	John Doe[/code]

Would it be possible for you to copy your .htaccess file code to http://paste.pagelines.com and then share the link with us.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vereggen

That's weird ... when I create a new user I get the dash same as you? It might be something to do with the way a user is created on the initial install of wordpress? I've uploaded my .htaccess code Link to site is http://rapidsuccesshabits.com

Share this post


Link to post
Share on other sites
vereggen

On my test site I went into the wordpress database and added a dash to the user db: wp_users field: user_nicename The author link worked. I've switched it back in case you want to check it out. I'm not sure if I'm hurting anything else in wordpress by doing this. It looks like the space is inserted for the admin during the initial install of wordpress. Also ... the base wordpress theme seems to strip out spaces on the author link.

Share this post


Link to post
Share on other sites
Danny

So this only happens when you create the admin user account ? Can you confirm this and I will create a new installation and test this.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vereggen

Confirmed ... this is only happening with the admin account ... it has happened on all six of my sites. I used Fantastico from my host provider to do the initial install. Whatever you put into - Admin nickname - gets inserted into the user_nicename field in wordpress - including spaces This is what is used for the author name link.

Share this post


Link to post
Share on other sites
Danny

HI, So I have just created a test website using MAMP Pro and the admin name contained a space for example Awesome Sauce. I then activated PageLines Framework 2.2.5 and changed the permalink structure to /%postname%/. Then refreshed the test site and clicked on the authors name which took me to the authors posts without any issue or 404. Therefore, this may well be an issue with Fantastico. I would always install Wordpress manually if I am honest. I have never liked Fantastico, when I did use it, I was always having issues.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vereggen

I also did a install without Fantastico and the author link worked fine with /%postname%/ So the source of the problem appears to caused by having a space in the user name when you build your site with Fantastico. For my other sites I updated the db: wp_users field: user_nicename and removed the space. Everything seems to be working ok. Tx for your help.

Share this post


Link to post
Share on other sites
Danny

No problem, was happy to help and glad to hear we find the cause of the issue :D


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×