Jump to content
Sign in to follow this  
aerta

Pagelines update problem

Recommended Posts

aerta

Just as I feared. Updated this site to 2.2.5 and it's completely crashed. I just get a page with the message: Parse error: syntax error, unexpected $end in /home/timriley/public_html/wp-content/themes/pagelines/sections/quickslider/section.php on line 127 THis has happened before. I'm very dubious about ever upgrading Pagelines again. Please - can someone help!

Share this post


Link to post
Share on other sites
Danny
Hi Aerta, Have you made any changes to the Quick slider section ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
aerta
No - no changes to the quick slider. I don't use it on the site.

Share this post


Link to post
Share on other sites
aerta
I guess my only hope of retrieving the site is to go in thru FTP and correct the syntax error. But I don't know what to correct it to!

Share this post


Link to post
Share on other sites
aerta
This is the code from wp-content/themes/pagelines/sections/quickslider/section.php: base_url.'/flexslider/jquery.flexslider-min.js', array( 'jquery' ) ); } function section_head($clone_id){ $animation = (ploption('quick_transition', $this->oset) == 'slide_v' || ploption('quick_transition', $this->oset) == 'slide_h') ? 'slide' : 'fade'; $transfer = (ploption('quick_transition', $this->oset) == 'slide_v') ? 'vertical' : 'horizontal'; $slideshow = (ploption('quick_slideshow', $this->oset)) ? 'true' : 'false'; $clone_class = 'pl-clone'.$clone_id; $control_nav = (!ploption('quick_nav', $this->oset) || ploption('quick_nav', $this->oset) == 'both' || ploption('quick_nav', $this->oset) == 'control_only') ? 'true' : 'false'; $direction_nav = (!ploption('quick_nav', $this->oset) || ploption('quick_nav', $this->oset) == 'both' || ploption('quick_nav', $this->oset) == 'arrow_only') ? 'true' : 'false'; ?> oset) || ploption('quick_nav', $this->oset) == 'both' || ploption('quick_nav', $this->oset) == 'control_only') ? 'true' : 'false'; $nav_class = ($control_nav) ? 'control-nav' : 'no-control-nav'; ?>
    oset)) ? ploption('quick_slides', $this->oset) : $this->default_limit; $output = ''; for($i = 1; $i <= $slides; $i++){ if(ploption('quick_image_'.$i, $this->oset)){ $the_text = ploption('quick_text_'.$i, $this->tset); $tlocation = ploption('quick_text_location_'.$i, $this->oset); if($tlocation == 'right_top') $caption_style = 'right:0; bottom: auto; top:0;'; elseif($tlocation == 'left_bottom') $caption_style = 'left:0; bottom:0; top: auto;'; elseif($tlocation == 'left_top') $caption_style = 'left:0; bottom:auto; top: 0;'; else $caption_style = 'right:0; bottom:0; top: auto;'; $text = ($the_text) ? sprintf('

    %s

    ', $caption_style, $the_text) : ''; $img = sprintf('', ploption( 'quick_image_'.$i, $this->tset ) ); $slide = (ploption('quick_link_'.$i, $this->oset)) ? sprintf('%s', ploption('quick_link_'.$i, $this->oset), $img ) : $img; $output .= sprintf('
  • %s %s
  • ',$slide, $text); } } if($output == ''){ $this->do_defaults(); } else { echo $output; } ?>
  • ', $this->images.'/image3.jpg', $this->images.'/image1.jpg', $this->images.'/image2.jpg' ); } /** * * Page-by-page options for PostPins * */ function section_optionator( $settings ){ $settings = wp_parse_args( $settings, $this->optionator_default ); $array = a

    Share this post


    Link to post
    Share on other sites
    aerta
    I've fixed it after a fashion: by copying and pasting the correct code from another site. Must say, though, I'm very wary of Pagelines updates!

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    ×