Jump to content
Sign in to follow this  
suerama

Tiled background disappears in IE7

Recommended Posts

suerama

This site has two pages. The tiled background starts disappearing when I am scrolling on the About page. No problem on the home page, so there is probably a fix. I know PL folks tend to pooh-pooh IE7, but my client, a coder, disagrees with your browser stats. At Nordstrom, one of his biggest clients, everyone has to work in IE 7 as the standard install. So I feel I have to fix this for him, but I'm code-ignorant myself. I'm trying to figure out what is different on the "about" page. Could it be the sidebar with the white background? Any help would be very much appreciated. Thanks!

Share this post


Link to post
Share on other sites
catrina
Are you using the background image setting to set the background or CSS?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
suerama
I am using the PL background image setting.

Share this post


Link to post
Share on other sites
Danny
Hi Sue, Please read this topic - http://www.pagelines.com/forum/discussion/17308/older-browsers-support#Item_1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
suerama
Thanks, Danny, now I'm convinced IE7 usage is low. But not sure how much that helps my client whose largest client, Nordstrom, uses it as the standard install. So I'm still working on this issue. I just read that backgrounds become problematic in IE 6 & IE 7 when the css order doesn't have the header items up top. So I went and changed the css order in my custom css areas. I used both the custom css ( which I use short-term and then I transfer that info to the pagelines customize plugin editor) and the css editor plugin. Here's my question: How does the css added to either of those areas affect the order of my items in the bigger css picture. BTW, Catrina: This was interesting: The sexy snips nav centering code did not center my nav when it was at the bottom of my PL customize plugin css editor. But when I moved it to the top of the css page, it worked.

Share this post


Link to post
Share on other sites
Rob
Suerama, I'd suggest that since PL is using CSS3 and HTML5, which post-date IE7, you consider using the old HTML and CSS versions via Custom Code > CSS Rules to apply the tiled background. Yes, I know it's backwards thinking, but if one's using an older browser, it's not forward thinking to use current tools. I'm sure you agree. Essentially, rather than using PL's built in background system, hard code it into CSS Rules. Make sense?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
suerama
Sure, thanks! Now I'll hunt down that code. Any suggestions would be welcome!

Share this post


Link to post
Share on other sites
catrina
Here's the background image code for further reference: http://www.w3schools.com/cssref/pr_background-image.asp :)

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
suerama
Much appreciated, Catrina. I'll try that tomorrow.

Share this post


Link to post
Share on other sites
Rob
Great.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×