Jump to content
Sign in to follow this  
ryanjohnjackson

adding " to "allow tags in excerpt" crashes IE9

Recommended Posts

ryanjohnjackson

Any other PHP or CSS suggestions for this issue: Trying to add a thumbnail image to my blog excerpt section on my homepage. To do so I add " to "allow tags in excerpt" for pagelines Works fine for Firefox and Chrome and IE8. BUT for IE9 it mangles the css for the page and goes into a force close loop. Also many other images disappear on the page. when I remove" to "allow tags in excerpt" all is fine again. --------------------------------------------------------------- I tried commenting out css related to that area = no luck I tried to block ie from seeing it using browser specific css but no luck: .ie .wpui-post-content img, .ie .wpui-post-content a{ display: none !important; } .wpui-post-content img{ border: 1px solid #cccccc !important; width: auto !important; height: auto !important; max-width: 120px !important; max-height: 95px !important; margin: 0px 6px 0px 2px !important; } -------------------------------------------------------------- This mod isn't currently not viewable to the public since 47% of our users use IE (sadly). I'm using: http://whiteplainslibrary.org Wordpress 3.3.2 multisite/network Pagelines Framework 2.1.6, base 1.0.2 Can't update to latest for a few weeks, it's a big todo for us. The issue is on both our test and live. Test isn't accessible to the public.

Share this post


Link to post
Share on other sites
ryanjohnjackson
To clarify my original question title was "adding " to "allow tags in excerpt"". Other tags have 0 problems.

Share this post


Link to post
Share on other sites
Rob
Questions: 1. Why can't you use the featured image? 2. Or tick the box to show it in the Blog page? Unfortunately, we can't diagnose broken HTML on a site that's not live.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ryanjohnjackson
The staff prefers to write text around the images in the blog post. That works on the blog page or in the post itself but I never wanted it in appear in my excerpt area on the homepage. Now it's required of me. I have it working it the other browsers but it kills IE9. The images already show on the blog page no issue. But the area at the bottom pulls the blog excerpt. That is partly controlled by pagelines. Browser specific css doesn't seem to help prevent it from effecting IE9 so I'm guessing it's some php level issue. I don't expect a fix since I think it's fixed in the current version but I can't update for a while due to other projects (plus we have an elaborate backup system and it has multisite/s). I was just wondering if there was a css way I didn't try or some function to pop in until we upgrade.

Share this post


Link to post
Share on other sites
Rob
When you say "The staff prefers to write text around the images in the blog post" do you mean like the onion in this? http://www.epicurus.com/food/onion Unfortunately, different browsers react uniquely to HTML code, as you know. I don't think there's CSS or a hook you can use to resolve this, but I could be wrong. I'd suggest however, that since the Excerpt is actually a WordPress item and not PageLines specific, you might find answers at WordPress. Also, another avenue might be seeking support for this from Microsoft. They might have a suggestion for how to write the code.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×