Jump to content
Sign in to follow this  
bxbmedia

Blog page template seems to be stuck on 'full width' layout

Recommended Posts

bxbmedia

The blog page of this site is set to use a sidebar on the right side, but it keeps coming up as a full width layout. I've tried setting it multiple times and re-saving and it seems to have no effect. See the page setup here: 11m585j.jpg Framework 2.1.6


gl hf

Share this post


Link to post
Share on other sites
batman
Hi @bxbmedia You can see in Pagelines > Settings > Website Setup > Hide Sidebars When Empty (no widgets) is enable or disable This allows you to remove sidebars completely when they have no widgets in them.

Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
bxbmedia
@batman - that option is not selected, and if you see the about page for example, the primary sidebar does have active widgets in it. You can see from the page setup image that the primary sidebar should be displayed on the page.

gl hf

Share this post


Link to post
Share on other sites
Rob
@bxbmedia, Please go to Dashboard > PageLines > Page Options > Blog Page and tell me if the Primary Sidebar is hidden there. I'm presuming the settings imaged above are on the static page.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
bxbmedia
@rangelone - those are 2.2 options. This site is currently using 2.1.6.

gl hf

Share this post


Link to post
Share on other sites
bxbmedia
I have upgraded one other site I run to 2.2.2, but there was really no reason for me to upgrade, and especially because I know how this has been a bit of a sensitive upgrade for some, I was opting not to at least at this time, just because there was no reason to right now. However, I did just upgrade to to see if that would resolve my problem. After upgrading, it had not fixed it, and all of my feature images were now missing. They weren't really missing, the urls were moved from background images to media images so I had to move them back (bug?). Everything else seems to be fine right now. I was able to fix the layout issue by trying @rangleone's suggestion of setting the default layout for the page under the "Page Options" for the blog page. So in the end, it's fixed, but I don't think I should have had to upgrade to do it.

gl hf

Share this post


Link to post
Share on other sites
Danny
Hi, It is highly recommended to keep both your theme/framework, Wordpress and plugins always updated, this is for security and compatibility reasons. Also for your interest if we were to go through the percentages, only a minority had issues/errors upgrading. You could also control the Blog Page template in 2.1.6, you simply had to go to PageLines > Meta > Blog Page.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
bxbmedia
Thanks Danny, My mistake, that setting is available as you say. Shouldn't the page's own meta settings override those set there? If not, shouldn't those settings be disabled on the page itself?

gl hf

Share this post


Link to post
Share on other sites
Rob
In theory, yes, they should. However some factors, such as plugins, customizations or erroneous code could cause the page settings to be overwritten by the global. It's worth looking for.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×