Jump to content
Sign in to follow this  
elyons3683

Change the logo on my blog - link to main

Recommended Posts

elyons3683

I was trying to change where the logo on my blog (www.holditbaby.com/blog) linked. It was linking to the main page of the blog, and I wanted it to link to the main page of the corresponding website (www.holditbaby.com). Wordpress is installed on www.holditbaby.com/blog only. When I made the change in Admin > Settings > General from the old URL (www.holditbaby.com/blog) to the new one that I wanted (www.holditbaby.com), the entire thing "blew up." I now can't even get into my admin panel to change it back and all of the formatting on the blog has been removed. How on earth can I remedy this????

Share this post


Link to post
Share on other sites
elyons3683

When I input www.holditbaby.com/blog/wp-admin, I get the following error message. It's as though it doesn't recognize that wp-admin is a folder, but I can see the folder on the server perfectly. Fs121.png

Share this post


Link to post
Share on other sites
bryan-hadaway

Yeah, that is probably the most common and easiest ways to mess up your blog. Ideally, there should be a warning right there, but onto the fix... You may have to ask your host to assist you in accessing your database for your blog, as you'll need to manually fix this. If your host is unable to help, let me know what you use and I can walk you through better. From your hosting accounts control panel you should be able to find: phpMyAdmin somewhere, go there. You might see a list of databases there, do you remember what you named it? Find it and click on it, now you should most likely see a list of tables starting with wp_. You're looking for wp_options, click on the first little "Browse" icon next to it. You are now looking at the rows for your main WordPress settings. The very first one should be siteurl. On that row you should see a little pencil icon, click on that to edit. Now change http://www.holditbaby.com/ back to http://www.holditbaby.com/blog - with NO trailing slash / on the end. So don't put http://www.holditbaby.com/blog/. Paste in exactly this: http://www.holditbaby.com/blog and then click "Go". Once you've got that fixed update us and we'll look into a better solution for you. Thanks, Bryan

Share this post


Link to post
Share on other sites
elyons3683

I appreciate that this may be inappropriate, but if you were in my personal space I would kiss you right now! There are not enough thanks in the world. Truly. I greatly appreciate you! Now, any ideas on how to get that icon to link to the main holditbaby.com page? Because I will NOT be trying THIS again! THANK YOU THANK YOU THANK YOU! Liz

Share this post


Link to post
Share on other sites
bryan-hadaway

There's a plugin that you can use called: Redirection. From your WordPress admin, go to: Plugins > Add New search for it, install and activate it. Now in your WordPress admin menu you'll find it's settings under Tools. You'll want to redirect: http://www.holditbaby.com/?page_id=307'>http://www.holditbaby.com/?page_id=307 to: http://www.holditbaby.com/ Thanks, Bryan

Share this post


Link to post
Share on other sites
elyons3683

That's actually what I did in the first place, but the system seemed to be getting confused. I was redirecting the Blog nav tab to holditbaby.com/blog and then when I tried to redirect holditbaby.com/?page_id=307 to holditbaby.com, it seemed to get confused and just sent it back to holditbaby.com. It was as though it were in some sort of loop. Any thoughts?

Share this post


Link to post
Share on other sites
bryan-hadaway

Actually, the redirect is working (look at the content), it's just leaving ?page_id=307 tagged on. If this is undesirable you could set your permalinks to a custom structure that might be far more desirable and SEO friendly anyways. You'll need to fix the redirect after this, but here the instructions for better permalinks: http://wordpress.org/extend/plugins/canonical-link/installation/ Find "Additional Instructions" on this page. Thanks, Bryan

Share this post


Link to post
Share on other sites
elyons3683

I've got the Home button working properly, but I want that star logo to the left of the nav bar to link the user directly to www.holditbaby.com and now it redirects to the home page of the blog. How can I remedy this?

Share this post


Link to post
Share on other sites
bryan-hadaway

Are you sure, everything seems to be working fine? Both from the blog homepage and website homepage, the star is linking to the website homepage. Perhaps try clearing your browser cache and cookies, restarting your browser and check again. Thanks, Bryan

Share this post


Link to post
Share on other sites
kellylazarus

I'm truly sorry for causing you this trouble. I was under the impression you had Wordpress installed in a separate directory and did not realize you were using redirects already. And I didn't actually surf to your site to see for myself... I've learned my lesson and won't be answering posts any more. Again, I'm really, really sorry. Brian, thanks for deleting the comment in the other post.

Share this post


Link to post
Share on other sites
bryan-hadaway

Hi Kelly, were happy to have anyone in the PageLines community help one another out. Please, just in the future make sure to do some research first, usually that just means asking a few questions because everyone's setup is different, and there are just so many variables for things to go wrong. No worries. Thanks, Bryan

Share this post


Link to post
Share on other sites
elyons3683

Kelly - From me as well, PLEASE don't apologize! I so appreciate everyone's help! I've answered questions in the forum previously as well with the best of intentions. I appreciate you for taking the time to try and help, and it's all sorted out plus I learned a few things in the process!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×