Jump to content
Sign in to follow this  
evoke2

Images not showing up

Recommended Posts

evoke2

Hey all, I first want to say that I love Pagelines and this forum has helped me a bunch with other sites I have created so this is my first post ever! (Be Gentle =) ) I recently created a new site on a subdomain www.theperfectcircleinc.com/test and I had the site finally completed and was moving it to www.theperfectcircle.com however everything works correctly with the exception of the images. When I go to Media Library I can view them all but they still have the www.theperfectcircleinc.com/test url instead of pointing to the new URL. Do I have to go into the database or somewhere to change this? If so how do I go about doing this? Regards, Gilbert Alvarez Evoke Media Studio

Share this post


Link to post
Share on other sites
Rob
Gilbert, I think we have two options here. Let's try the easiest first. Go to Dashboard > Settings > Permalinks. Don't change anything. Just click the Save button. This will rebuild all the links inside the www.theperfectcircleinc.com/ site to update things from www.theperfectcircleinc.com/test. Before we get into the second option, let's see if that works.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
evoke2
That did not work. I have actually gone in and changed the URL manually of each picture. However some of the links inside of the pages I have also show that /test in the URL. I have also notice that the pages load kind of slow and in addition when i go to edit a page I do not see any of the text in the Visual Tab area nor any of the buttons like italic, bold, bullets, add link etc. In addition if I want to edit a page, the only way i am able to view any information on the page is by clicking in the Code Tab section

Share this post


Link to post
Share on other sites
Rob
When you went to save the Permalinks, did you scroll down and see any instructions from WP? It's possible you need to change the permissions of your .htaccess file to be writable before the permalinks will update. How did you migrate the data from /test to the main domain?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
evoke2
well it was a cluster. At first I just went into General and changed both URL's to reflect the new one. ( I wasn't really thinking clearly I guess) So that broke everything. I then had the hosting company try to fix it for me and they ended up just moving all of the file from the /test folder in the folders to the main root (That just got me a nice gray page) I then contacted the hosting company again and they were able to get my files more or less working again however I had to reinstall PageLines Framework 2.1.6 and Base Theme 1.0.2 which to be honest I am not sure which one I should have active. ( I tried them both) Now I have the current problem at hand.

Share this post


Link to post
Share on other sites
Rob
The norm would be to use the PageLines Framework export function to create an file you should have imported to grab all your PageLines settings. In Dashboard > Tools > Export, you could have exported all your posts to another file you could have imported into WP via Dashboard > Tools > Import. But since that's all water under the bridge, the issue now is going to be updating your links to the new site without having to reset every link by hand. I'd suggest http://wordpress.org/extend/plugins/search-and-replace/ be installed. BE VERY CAREFUL USING IT. Don't rush. Think twice, take a cold drink of water, and then think twice again. You'll want to do a search for [b]theperfectcircleinc.com/test[/b] and replace it with [b]theperfectcircleinc.com/[/b]. This may result in double '/' marks. In that case, you'd do another search for [b]theperfectcircleinc.com//[/b] and replace with [b]theperfectcircleinc.com/[/b]. Why does this work? Because the plugin literally writes directly to the database ignoring public posts and going right to the heart of your records.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
evoke2
Rangelone, Thank you very much for your time and help! I am going to try this out. I will post back later on to let you know how it went.

Share this post


Link to post
Share on other sites
evoke2
Ok i was able to install Search and Replace and it did find a ton of instances of the wrong URL. That was great. However I am still having the issue that I cannot view "The Kitchen Sink" when viewing any post in Visual Mode although I am able to see text using the HTML Mode. Any ideas?

Share this post


Link to post
Share on other sites
evoke2
I noticed that you had me search and replace "theperfectcircleinc.com/ " however under General Settings I have; WordPress Address (URL) "http://www.theperfectcircleinc.com" and under Site Address (URL) "http://www.theperfectcircleinc.com" should I add the forward slash at the end?

Share this post


Link to post
Share on other sites
Rob
You may have an incomplete WP installation. Just FTP into the site and upload your WP files again in everything except the wp-content folder (only wp-admin and wp-includes and base files). Let us know if this works.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
evoke2
upload WP files not Pageline files?

Share this post


Link to post
Share on other sites
Rob
Not necessary to add the / at the end. I was including that to ensure that the links that have things after the .com are not broken. You'd not want to see .comimages instead of .com/images.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob
Yes, Wordpress files and not PageLines. The kitchen sink and post/page editing is a WP function, not a PageLines function. In fact, you may wish to check http://www.wordpress.org in case others have had this issue.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×