Jump to content
Sign in to follow this  
tandan

css questions

Recommended Posts

tandan    0
tandan

Hi there, A couple of questions that I'm stumped on: 1) I used the following css on my site: www.familydanz.mpwclient.com to have an image repeated on x as then white below:

#content {
	    background: #ffffff url("http://familydanz.mpwclient.com/wp-content/uploads/2012/05/content_bg.jpg") repeat-x;
	}
which looks great in firefox but on safari (haven't checked explorer or chrome yet) this doesn't seem to work and the top gets cut off (where there should be a gradient above it)...here's a pic of it...is there any way to work around this? hZTs6.png 2) also, on safari, as you can see from this picture, the features slider isn't the same height as the blue behind it...there's extra blue below it...how can i fix this? lxexv.png 3) Lastly, I tried hiding the home page title with the following code but it didn't work even though it worked on another PL site I have...
body.home #post-15 h1.pagetitle {display: none;}

Thanks so much for your help in advance!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Hi TanDan, 1. This is caused by your custom CSS for your #header and the height being set to 130px. You will need to adjust this to resolve the problem. 2. You CSS has one part set to 260px, this is the cause of the issue. [code].fset_height, #feature_slider .text-bottom .fmedia .dcol-pad, #feature_slider .text-bottom .feature-pad, #feature_slider .text-none .fmedia .dcol-pad { height: 260px; }[/code] Settings this to 300px should resolve the issue. 3. Try this instead. [code].home .pagetitle {display: none;}[/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tandan    0
tandan
@danny , thanks for your reply! 1) I set my header to auto and it fixed the issue in safari but the problem is that I want to decrease the space between the navigation bar and the features/content area below it. What would be the "correct" cross-browser compliant way to do that instead of setting it the height to 130px? 2) by setting this to 300px, after fixing the above issue, I now have all this extra blue below and above the features area--how would I get the features area to be flush with the slider which is my goal? 3)I tried your code and it didn't work. I placed it into the custom css area... Thanks so much for your help!! I'm learning! :)

Share this post


Link to post
Share on other sites
tandan    0
tandan
if anyone else has any tips for this, it would be greatly appreciated as well! :)

Share this post


Link to post
Share on other sites
catrina    103
catrina
[quote]1) I set my header to auto and it fixed the issue in safari but the problem is that I want to decrease the space between the navigation bar and the features/content area below it. What would be the "correct" cross-browser compliant way to do that instead of setting it the height to 130px?[/quote] I think the top margin for the features area would need to be adjusted (further documentation: http://w3schools.com/css/css_margin.asp). [quote]2) by setting this to 300px, after fixing the above issue, I now have all this extra blue below and above the features area--how would I get the features area to be flush with the slider which is my goal?[/quote] Are you only seeing this in IE? (I don't see the issue in Firefox) [quote]3)I tried your code and it didn't work. I placed it into the custom css area...[/quote] Try this CSS instead: [code]body.home .pagetitle {display: none;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
tandan    0
tandan
@catrina, i actually figured out 1,2 but 3 is still not working. I used what you gave me above... I don't know why it's not sticking. :(

Share this post


Link to post
Share on other sites
catrina    103
catrina
Two elements in the code were wrong. Sorry: [code]body.home h1.entry-title.pagetitle {display: none;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
tandan    0
tandan
@catrina, hmmmm still not working. :( i've put it in the custom css box right now. don't think it's conflicting with any other css...

Share this post


Link to post
Share on other sites
Jenny    33
Jenny
[code].home h1.entry-title { display: none; }[/code] .. should work.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
tandan    0
tandan
@simple_mama, thanks so much! it totally worked!!! i don't know why (part of the problem and i wish i could figure the logic out) as in firebug I got something else... and it seems others are getting other code as well so it's not just me (??) but in any case, i'm happy that it's good now and glad in 2.2 there will be an option to select if it appears on a page or not! Thanks again!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×