Jump to content
jankowalski

post clips size

Recommended Posts

jankowalski    3
jankowalski

post clip image is served in full size. i am talking about magazine mode. how to change that? it does slow down my page.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Jan, If I understand you correctly, do you want to change the image size in Magazine mode ? Also can you provide a link to your site please or is this local ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

yes you understand correctly. just standard instalation with blog in magazine mode.

Share this post


Link to post
Share on other sites
Jenny    33
Jenny

If you inspect the magazine image using Firebug (or similar) you will see the following:

[/code]

	
	And the CSS shows:
	
	
[code]element.style { max-width: 150px; width: 25%; }
Which means it is inline CSS styling. To change this, you will need to adjust both the max-width and the width values to whatever you want. To make sure it only applies to the clip's CSS, you'll need to start out by using
.clip_box

.. and then go from there using the CSS from the link I posted at the top.


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

i don t want to resize down the image, i want to load thumbnail instead. As i can see the image is using class img.attachment-large.wp-post-image Is magazine mode, a pagelines functionality or it comes from wordpress? if it pagelines layout, then it should be modified, i dont see a reason to load full size image on post list.

Share this post


Link to post
Share on other sites
Simon    247
Simon

magazine mode uses the thumb images for the image if they exist.

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

how do i create thumbs, in admin panel, in settings / Media i set thumbnails 100 x 150 in Media / libary this particular picture is 600 x 400 px how do i make sure i have thumb generated for this picture thou? i guess i do not have, if full size pictures are loading on blog page.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Jan, Are you by any chance using the "Feature Post Excerpt Mode" option "On Top" ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

yes @danny i do use this option

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, because I just used that option and found that the image was also full size, I think this may well be a bug with that option (nice catch). I'll add this to the tracker on your behalf, thanks for bring this to our attention.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon    247
Simon

The image on top option is supposed to be full size, thats the idea

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

@Danny thank you for adding it, but what does it actually mean, when it is going to be fixed? @Simon idea is good for detailed blog page, but not for main page (archive) where you have to list 6 or more posts, they are beeing resized donw by css anyway, so it does make no sense to serve them big. just make page loading slow. Google don t like it, when i analyze my website here https://developers.google.com/pagespeed/ the first thing they say is SERVE SCALED IMAGE If you have diferent idea, could you please be so kind to provide me a hack so i can call thumb on archive page? thank you

Share this post


Link to post
Share on other sites
Simon    247
Simon

Not sure what you mean, when the images are set to 'top' they are full size, not scaled. If you can post a link it might be helpful.

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

@simon on single blog page, i set the "Feature Post Excerpt Mode" option "On Top" under "Blog and Post" so image apears above the title. on single post page it is necessary so it apear big on archive page i wish to have 6 thumbnails instead of 6 resized by css fullsize pictures, in my last post i explained why. hope you get the idea.

Share this post


Link to post
Share on other sites
catrina    103
catrina

I'm not an experienced enough coder to give you pointers about how to 6 thumbnails display specifically in the archive page. By "6 resized by css fullsize pictures" are you referring to just regular images added inside the post and resized rather than uploaded as featured images (this sounds like a do-able workaround)?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

you can set 6,5 or 8 posts in worpdress settings, it doesn t mater, i m not asking how to display it, it is already done by magazine mode. what i am talking about for 3 days now is that those pictures should be served as small images because as you have noticed it is kind of do-able workaround. @danny also noticed that it is a bug.. Now, could anyone please tell me how to fix it? @simon i have send you link by priv.

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

@simon i want to have my clip image on blog page on top of the post, so "Left, In Excerpt " is not what I am looking for... I know it works like this. But if this option is displaying thumb, why "on top" can not work the same way? there is no way a full size image will fit on 2 column magazine mode layout, so it really has no sense, and 2 people already admit it. i know this full size option on blog page is probably necessary for "Blog Layout Mode" and if developers want to leave it as is it s ok, but please tell me which file should i edit, so i can replace this image class in magazine mode. i really need it.

Share this post


Link to post
Share on other sites
Simon    247
Simon

The file would be class.posts.php function is post_thumbnail_markup() I strongly suggest to not edit this or any file! There is a filter supplied in this function for you to change the markup:

return apply_filters( 'pagelines_thumb_markup', $output, $mode, $format );

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

Thank you, this is promising after all those unnecesary mails. Sorry, I m not familiar with filters, so where can i learn about it? I d like to set thumb size 200 x 300 px for magazine mode. greatings.

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

do you mind to give me an working example of this filter, so i could play with this code? i have no idea about php.

Share this post


Link to post
Share on other sites
catrina    103
catrina

Unfortunately, I'm not much of a PHP person either and I'm not a developer. : I think @simon would be better at explaining. An explanation from me may not be the best! Tutorials that describe WP filters more in-depth and have examples may be helpful, though.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

no sign from @simon ...

Share this post


Link to post
Share on other sites
jankowalski    3
jankowalski

i explained 5 times what i want to do, and i didn t get a solution for 9 days now.. this is a bug in platform framework, and instead of giving tips, i would expect to have this problem fixed by developers! am i wright?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×