Jump to content
Sign in to follow this  
scottimpactyourcompanycom

404 error messages

Recommended Posts

scottimpactyourcompanycom

Gentlemen, I tried looking for a solution in other posts but couldn't find any. I have a 404 error message coming up on pages of my site. Here are a couple- http://blazemarketinginc.com/thank-you http://blazemarketinginc.com/how-search-engines-work I've found that when I log out of the site internally, the 404 error messages take effect immediately (as opposed to just shutting down the browser). However, when I just shut down the browser, the 404 error messages come back about half the time. My guess is that the logging out process doesn't really have a whole lot to do with it...just trying different things. I need these pages to stay up. Can you offer a solution? Thanks in advance, Scott

Share this post


Link to post
Share on other sites
wp101

Hey Scott, Are you sure that your pages are published and not set to draft? It seems that way if you can see them when logged in but not otherwise.

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

They're all privately published (the ones in question). The reason I list them that way is because I don't want them listed in the top navigation bar. Do you think that's the source of the problem? When I publicly publish them, they all turn up listed on the top navigation bar.

Share this post


Link to post
Share on other sites
wp101

Scott, yes. I do believe that to be the source of it.

Private content is published only for your eyes, or the eyes of only those with authorization permission levels to see private content. Normal users and visitors will not be aware of private content. It will not appear in the article lists. If a visitor were to guess the URL for your private post, they would still not be able to see your content. You will only see the private content when you are logged into your WordPress blog.
http://codex.wordpress.org/Content_Visibility#Private_Content If you don't want the items to show in the nav bar, perhaps you can exclude them for the time being using the Menu settings (WP3)

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

This whole time, I thought my associates could see those pages. Ok, can you give me some direction on how to exclude a page from the nav bar after I make it public? Thanks, Talha

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

By the way, each of the published pages now on the nav bar have been given an order number under the page attributes. If there is a way to manipulate the menu settings for the top nav bar to just include those pages (1-7...including the home page), then I think this problem would be solved. I would then make all the pages public and the nav bar would only show those 7 pages. Problem is, I can't find that menu setting option.

Share this post


Link to post
Share on other sites
Andrew

have you tried using either the 'exclude pages' plugin or the new WP 3.0 menus?

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

exclude plug-in works great! thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×