Jump to content
Sign in to follow this  
rpacker

Controllling the thumbnail in Facebook sharing

Recommended Posts

rpacker

I have had a devil of time trying to incorporate the correct thumbnail when you share a post to Facebook. I am using the Sharedaddy plug-in, but I believe this is a Wordpress issue. Sharing will not take the featured image, which is of course what I want. Instead, it gives me a choice of thumbnails that are drawn from the sidebar, including a Flickr stream, but not an image contained in the post itself! I would be forever indebted if someone can crack this problem, it's been on and off with each Wordpress revision. Thanx.


Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
facebook uses the 'og' data in the page header, if you add a featured image to the post, the framework itself will add the og data for that image automatically and FB should see it and use it, without the data fb just uses the first image it sees.

Share this post


Link to post
Share on other sites
rpacker
I wish you were right, but it isn't working that way on my site. Go to this page: http://www.randallpacker.com/?p=2297 and click on the Facebook share button and you'll see what I mean. You don't have the featured image as a choice of thumbnail.

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
Thanks for the instant rejection. There is no featured image in your post.

Share this post


Link to post
Share on other sites
rpacker
sorry, I guess I'm not clear what the "reject" button means... Anyway, there is in fact a featured image, it's the photo of the radio dj. Do you have any suggestions why this featured image isn't available as a thumbnail?

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
That DJ is just an image in the post it is not a wordpress featured image.

Share this post


Link to post
Share on other sites
rpacker
Yes it is! What makes you think it's not? I made that image a featured image in the post. What do I have to do to convince you? I have a screenshot from the dashboard, but I"m not sure how to embed an image in this post.

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Danny
Randall, That image in your post is not a Feature image, you have added that image to your post. When you add a feature image to your post it is given a class like this .post-thumb. Your image has no such class. Therefore I recommend you read through the Wordpress docs regarding how to add a feature image to your post. http://codex.wordpress.org/Post_Thumbnails#Setting_a_Post_Thumbnail

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rpacker
Danny, I use featured images all the time and that image is set as a featured image in this post, so I have no idea what the problem is. See next post for screen shot...

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
rpacker
Danny, I just uploaded a screenshot and have included the link below of the DJ image set as a featured image in this post: http://www.randallpacker.com/wp-content/uploads/2012/05/featured_image.png The question is, since I have set this image of the DJ as a featured image, why isn't it functioning that way? Is it possible there is CSS code conflicting?

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
can we see a shot of the whole post page

Share this post


Link to post
Share on other sites
rpacker
I assume you mean the whole dashboard page. Here it is broken into two screenshots: http://www.randallpacker.com/wp-content/uploads/2012/05/featured_image_02.png http://www.randallpacker.com/wp-content/uploads/2012/05/featured_image_03.png Thanks, Randall

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
http://screencast.com/t/faGT2VIXw I have highlighted the image for you, that is a normal image inserted to the post. You do not have post thumbs turned on for single post pages, thats why the featured image is being ignored. Look under 'Blog and Posts' section of PageLines settings.

Share this post


Link to post
Share on other sites
rpacker
I appreciate the suggestion but I think you are misunderstanding my question. I don't want to display the featured image thumbnail, I just want it to be able to share it to Facebook. Even with the thumbnail turned on for individual posts, when you share the post to Facebook, the featured image thumbnail is NOT available. I have it turned on so you can see the duplication of the image on the post page, and still if you try and share this post to Facebook, the featured image is NOT available. http://www.randallpacker.com/?p=2297

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Jenny
I do the same thing @rpacker so I understand what you're saying. Automatically using the featured image within a post causes issues on my sites as I am constantly changing the width of those images according to how I want the post to look. Checking a box to have this done automatically is more of a hindrance than a help, to me at least. Hopefully this can get sorted out as I would love this ability as well.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
Simon
Do you have the og data system on? Its under advanced, or are you using yoasts plugin to do it?

Share this post


Link to post
Share on other sites
rpacker
Your questions are beyond my knowledge of Wordpress. What does "OG" stand for? I don't see anything resembling that in the Pagelines advanced section. I also don't know what the Yoast plugin does.

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
from your page source: [code][/code] From that i deduced you have yoasts SEO plugin installed, it has an option to display facebooks opengraph[1] data in the HEAD of you page. Also under 'Header and Footer' settings you will see [b]Enable Facebook Open Graph data[/b] this enables the PageLines implementation. I have no idea which one you have enabled, and I do not know yoasts code will pull the featured image, but ours will. [1] http://ogp.me/

Share this post


Link to post
Share on other sites
rpacker
Thanks Simon. OK, I have turned on open graph data in the SEO settings and have made myself a Facebook admin. I also enabled "Enable Facebook Open Graph Data" in the "header and footer" Paglines settings. Now my Facebook sharing doesn't show up: http://www.randallpacker.com/?p=2297

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
Look at view-source:http://www.randallpacker.com/?p=2297 the source of the page, at the top, you have the og data there twice now.

Share this post


Link to post
Share on other sites
rpacker
So what do I do? I just turned off ogd in the SEO settings and the sharing still isn't there. So then I turned off the Pagelines ogd settings and the sharing is back. Can you provide me with a solution?

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
Simon
OK a quick look shows sharedaddy adds its own og:description. try this fix: Open includes/library.templates.php and look for this: [code]printf( "n", pl_short_excerpt( $fb_content, 15 ) );[/code] Change to: [code]if ( ! function_exists( 'sharing_plugin_settings' ) ) printf( "n", pl_short_excerpt( $fb_content, 15 ) );[/code]

Share this post


Link to post
Share on other sites
rpacker
Thanks a million for the suggestion. However, I don't feel confident changing the template code, particularly since it doesn't exactly match your highlighted code, This is what I found: printf( "n", get_permalink($pagelines_ID)); Also, if I do make a change, will it be overwritten with the next revision of Pagelines? Randall

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites
catrina
If you're using Base theme and editing the file in there, an update shouldn't overwrite it.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
rpacker
Thanks Catrina, I'm not using a base theme and again, i don't feel confident editing the templates. Is this something I could pay one of the experts to do?

Randall Packer

Multimedia Artist & Educator

http://www.randallpacker.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×