Jump to content
gyoery

Mediawiki Default skin Pagelines

Recommended Posts

gyoery

I installed mediawiki to one of my sites, and the skin seems to be working for registered users who select it. But when I set

$wgDefaultSkin = "PageLinesWiki";

it doesn't have any effect on anon visitors. Reff: scr_mediawiki_pl_skin.png Help is appreciated.

Share this post


Link to post
Share on other sites
gyoery

of course - meticulously - , as I said, it is working for users, so it has to be integrated the right way... PS: Please don't say: "Well, then it ain't our problem"

Share this post


Link to post
Share on other sites
Danny

Hi Gyoery, I have just completed a test install and there is no issue with the PageLines MediaWiki theme/template not working for guests. My quick test installation works both for logged in users and guests. Therefore, you either have no followed the steps in the MediaWiki integration documentation correctly (maybe missed something) or you have something that is causing the conflict. Are you using any script or plug-in for membership ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
gyoery

I am using a mediawiki extension for WP logins, but I had that issue b4 as well. I will try disabling it and report back. Checked: It has nothing to do with the extention, tried deactivating. I read in other forums that if changing the $wgDefaultSkin after install, it is already copied into the userdata. Maybe there is some _VISITOR user data, or something like that??

Share this post


Link to post
Share on other sites
Danny

Hi Gyoery, I apologise but I am not sure what you're referring too. I simply followed the instructions available on the documentation for MediaWiki integration and the theme worked as expected. Would it be possible to reply and list all the steps you took please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
gyoery

I did you one better: http://pastebin.com/7Qd4xQcJ <-- LocalSettings.php (personal info removed) Filestructure: scr_mediawiki_pl_skin_fstructure.png All files copied and Settings configured. @ this point: "Navigate to your MediaWiki Appearance page to see the PageLinesWiki theme listed. You must be logged in as an Administrator MediaWiki Home Page=>My Preferences=>Appearance " I did that, but that only changes the skin for the admin, not for all visitors. The doc says nothing about how to change it for other users and visitors. So please tell me how it is done correctly for the visitors.

Share this post


Link to post
Share on other sites
Danny

Hi Gyoery, Open up your "LocalSettings.php and find this line:

## Default skin: you can change the default skin. Use the internal symbolic
	## names, ie 'standard', 'nostalgia', 'cologneblue', 'monobook', 'vector':
	$wgDefaultSkin = "vector";
Replace with:
## Default skin: you can change the default skin. Use the internal symbolic
	## names, ie 'standard', 'nostalgia', 'cologneblue', 'monobook', 'vector':
	$wgDefaultSkin = "pagelineswiki";

I haven't really played around with MediaWiki much, so there may be an easy way to do this. I will make sure this is added the MediaWiki integration documentation.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
gyoery

well, that is almost exactly what I did. That is where the problem arose. Anyway.. luckily you have still helped me, as my mistake was to use $wgDefaultSkin = "PageLinesWiki"; (as it is called in skins) and not $wgDefaultSkin = "pagelineswiki"; (nocaps) So thanx anyways.. It is working now.

Share this post


Link to post
Share on other sites
Jenny

Thanks for the update @gyoery. Glad you got it working. If you consider this topic resolved, please accept an answer. Thanks!


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
grabowskit

I had this same issue. You may want to add it to the docs page. (MediaWiki 1.19.1) thank you.

Share this post


Link to post
Share on other sites
trebord_55

I also had this issue, and Danny's fix resolved it. :) Would second @grabowskit's rec that you add it to the docs page ( http://www.pagelines.com/wiki/How_to_Use_Integrations#Install_the_PageLines.2FMediaWiki_Integration ).

Also, regarding the instructions on that page, in my experience the code insert for LocalSettings.php needed to be on three lines, not one, in order to work; thus:

// pagelines-start

require_once( '/home/user/www/wp-load.php' );

// pagelines-end

Thanks.

Share this post


Link to post
Share on other sites
Rob

Thanks for your suggestion!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×