Jump to content
Sign in to follow this  
onlinetracker

MediaWiki install gone wonky.

Recommended Posts

onlinetracker

So, I installed the Wiki under /wiki/ and followed the directions right up until I got here: Select the "PageLines" panel, then "Special" You will now see a new "MediaWiki" tab along with the rest of the Special Pages Everything was fine and its integrated, but when I went back to the PageLines panel to remove the various items like Boxes, Banners (currently deleted so you won't see them) and Features, they still display. Also, on my Install of Pagelines Framework, I don't see a "Special" tab, I think that is now called Meta. What did I miss? I followed this: http://www.pagelines.com/wiki/How_to_Use_Integrations#PageLines_MediaWiki Thanks

Share this post


Link to post
Share on other sites
Danny
Hi, First things first, the "Special" settings panel was renamed to "Meta", thank you for bringing this to our attention. I have forwarded this onto our docs team, for them to amend. Secondly, you have both the Features and Boxes section in your header template. Placing sections such as these means they're visible on all pages/posts/categories etc... Therefore, if you wish to hide these sections on your MediaWiki powered page you have two options. 1. Remove them from the "Header template". 2. Go to Meta > MediaWiki and then simply uncheck the boxes next to these sections.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
onlinetracker
Danny, 1: I want the boxes site wide and then removed as necessary, such as the MediaWiki integration page. 2: Unchecking boxes in the MediaWiki meta page unchecks options named "Hide (Boxes/Feature/etc)" which is the opposite of what I want to do.

Share this post


Link to post
Share on other sites
Rob
I think Danny made an honest mistake there. Let me apologize for that. If you want to hide the boxes or feature, you check the box, as you correctly surmised.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
onlinetracker
I know, but checking the boxes does nothing unless there is something else misconfigured. Everything works except for removing boxes, features and banners.

Share this post


Link to post
Share on other sites
Rob
The reason the hide function may not work is that it may be trying to hide only within the template, as opposed to globally throughout the site (as in the Header). Since MediaWiki uses a different template from the Default, perhaps you need to add it to the Page Templates in the Default, rather than the Header, which MediaWiki will pick up. I've not tried this, so it's just conceptual.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob
Simon has tested things and has reported this issue as a bug. http://pagelines.com/tracking/pagelinesframework/issues/62 You can follow its progress there.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
onlinetracker
Thanks for the due diligence.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×