Jump to content
Sign in to follow this  
ksnyde

Page settings refuse to update

Recommended Posts

ksnyde

I've created a custom template called "Application Page" by copying the page.example.php to page.application.php. I then go into Pagelines -> Themes and configure this new page type to have "Quickslider" followed by "Boxes" (turned off by default) and then "Content." So far no problems. I then create a page called Report Center and use the Application Page template. After publishing the page I realised I needed to make a few changes. For instance, I needed to turn off the comments for this page. I went into the page and under the PageLines Meta Settings I choose to hide comments. I click on "Save Meta Settings" button and it says "Page Updated" at the top of the page. It appears all is well but it is not. An inspection of the PageLines Meta Settings shows that the "hide comments" is no longer checked off! I need help solving this but I did notice that some of the options (those things that have a checkbox config option attached to them) have one of two colours as a background. Those with the darker background -- this is a strong theory not absolutely proven -- seem to behave this way but I have no idea why they'd be greyed out and clearly being able to disable the comments on a page is something that shouldn't be disabled. Here's a screen shot of the Pageline Meta Settings panel: http://www.flickr.com/photos/14261777@N00/7067842921/

Share this post


Link to post
Share on other sites
Rob

Ken, what are the Meta Settings in Dashboard > PageLines > Meta as those are global settings and would apply to any section used in a template, where the page meta settings only apply to that specific page. If there's something amiss on the global level, then the page meta might not have the right effect. Can you check that ant let us know? Thanks Ken. Sorry for this extra step but it's a process of elimination.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ksnyde

@rangealone, which section in Meta are you interested in? I'm assuming just the global settings as these seem to be the only that are in scope for this query. Based on that assumption, here's a screen shot of the page: [http://www.flickr.com/photos/14261777@N00/6922860432/]. Obviously with a screen shot I had to choose a particular section to focus on. I chose boxes but I looked at the others and they all appear to be in the default state (as far as I can tell). Also, none of these settings seem to directly impact Comments (although Comments is just one example of what's not working).

Share this post


Link to post
Share on other sites
ksnyde

The environments i'm working on are not publicly accessible but I may be able to push this problem into a publicly accessible environment if you need "hands on" work with this environment.

Share this post


Link to post
Share on other sites
ksnyde

Ok, I've got it up into a publically accessible area and it definitely is repeatable. Without too much testing what appears to be happening is that I can't change settings for custom templates that I create whereas I can for the default template (and I'd guess the other standard templates). The URL is: http://test123.lifegadget.co/testpage/ I've given you editor rights (which should be enough) to demonstrate this problem. Ken

Share this post


Link to post
Share on other sites
catrina

Thanks for the log-in. I followed the steps you did on the test page and I'm getting the same results. I'm also getting the same results when I select page templates other than the Application Page template, so I don't think it's an issue with the page template you select. Have you already tried deactivating your active plugins to see if the meta savings save correctly?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ksnyde

Try setting the template to the default template and then you can change the settings. Take a look now, it's on "default" and I've turned off the commenting with no problem.

Share this post


Link to post
Share on other sites
catrina

Ah, yes, I see that. I want to look at the PageLines > Meta settings you have but I don't have the privileges to do so (I already saw the screenshot you posted previously).


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ksnyde

Ok, I'll give you admin. Let me know as soon as I can downgrade it.

Share this post


Link to post
Share on other sites
Rob

Ken, please send a private message to Catrina with the login details. I'm editing the earlier post to remove the login details as this is a public forum and accessible via Google. You don't want strangers in your site with Admin access. Change the password too, for safety sake.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ksnyde

Thanks @rangealone. I was a bit uncomfortable with that. Catrina please check you inbox for update.

Share this post


Link to post
Share on other sites
Danny

Hi Ken, I have just created a custom template, created a new page using that template and then successfully hidden the Quick Slider section and Comments section. Therefore, can you disable all active plug-ins and see if this resolves the issue please. Also, you're using version 2.1.5, the latest version is 2.1.6.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
ksnyde

I have 2.1.6 in another environment and it exhibits the same problem. @Danny, when you say you did this, do you mean in my environment or in your own? I'll try disabling all plugins but as there are a number of concurrent threads in all my environments I'll have to wait on this step. @Catrina, have you tried logging in with Admin rights? Any thoughts based on that?

Share this post


Link to post
Share on other sites
catrina

I logged in successfully and looked at your Meta settings but they appear to be working fine (I don't think they have anything to do with the behavior of the sections you want to hide).


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ksnyde

Yes the Meta Settings should pretty much be default I'd think. Can either of you tell me if the greyed out background on some of the page options is a normal thing in Pagelines?

Share this post


Link to post
Share on other sites
Danny

Hi Ken, Can you post screenshots of the page settings in questions please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
ksnyde

Danny, which screens do you need? BTW, I have restored the database to the clean production status and have disabled ALL plugins and it still doesn't work. This is all in my local environment so I can't show you this but please be specific about what you need and I'll get it to you. I am desperate to get this fixed as I have an investor pitch on Friday.

Share this post


Link to post
Share on other sites
Danny

Hi Ken, If you're doing this locally, what software are you using and what version of PHP/MySQL do you have installed ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
ksnyde

MAMP install. PHP is 5.3.6. mySQL is 5.5.9.

Share this post


Link to post
Share on other sites
Danny

Hi Ken, OK, well you have the same setup as me and you're still having the issue. The only other reason as to why you would be getting this error is if you have add custom code somewhere, is this the case?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
ksnyde

I'm really not sure @Danny. Please check out my test environment at: http://test123.lifegadget.co. Login as Pagelines (I'll send you a password privately): - All plugins are disabled - In the Admin interface, goto the "App" page which is of the template type "Home Page" - Try to disable the "comments" and update meta settings ... IT DOESN'T WORK!

Share this post


Link to post
Share on other sites
ksnyde

I have ALL plugins disabled. I run a child theme and I have followed the very simple steps outlined in the instructions. I'm 99.9% sure I've set this up the right way. @simple_mama, I'll send you the username and password privately too so you can take a look.

Share this post


Link to post
Share on other sites
Rob

Ken, sorry I've been out of touch. Does the ability to save settings still remain encumbered? If you have a plugin for Cache and it's disabled, it doesn't mean the cache is cleared. You may have to reactivate it, clear the cache and then deactivate immediately. Sounds crazy, but if there's something in the cache preventing you from saving, just deactivating the plugin won't erase that thing.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×