Jump to content
Sign in to follow this  
jjagerson

home page won't show as logged in

Recommended Posts

jjagerson

We use widgets in the sidebar to manage login. When a user logs in there's logic that switches the widgets from a logged in view to a logged out view. For some reason this logic works great on every page except the home page of our site. We did determine that the reason appears to be that the home page ALWAYS shows you as logged out, regardless whether you've logged in or not. Any ideas why the home page is always showing as logged out? (We are using a static page as our home page, if that helps.)

Share this post


Link to post
Share on other sites
gyoery
What plugin or logic do u use? Keep in mind that your Landing Page is in a parent folder then all your other pages. So maybe the call to your logic must be adapted accordingly. This would be my first guess, but probably there is more to it.

Share this post


Link to post
Share on other sites
jjagerson
Thanks -- that is a good guess. We're using "display widgets" for widget logic and it's working well. That was my first thought, too, but then I noticed the admin "[edit]" links were also missing form the home page. So even though the sidebar isn't loading what we want, I realized the Display Widget logic is technically working correctly because the home page is loading as if I were logged out. That's the mystery. We've tried deactivating a bunch of plugins to see if one of them might be causing the problem but so far to no effect.

Share this post


Link to post
Share on other sites
catrina
Have all plugins been deactivated at once? Have you considered contacting the plugin creator about this issue or activating a different theme and seeing if the issue persists?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
gyoery
Probably this wont fix it, but consider checking out: "Widget Logic Visual" that is what I am using.., and it seems 2 work like a charm. Also it would be nice to have a test user account with edit privilages to see for ourselfs...

Share this post


Link to post
Share on other sites
Danny
Hi, If you switch theme to Twenty Eleven, does the issue still remain if so then you will need to contact the plug-in author for assistance. If the issue doesn't remain when switching to Twenty Eleven, please reply here.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×