Jump to content
Sign in to follow this  
freshlightstudios

Features container not right and cutting off video controls

Recommended Posts

freshlightstudios

I have Pagelines Framework. I working with the Features and embedding video into it. Features is leaving a larger container with black background around the video's sides and bottom. If select aspect ratio and increase the size of video to fit the container it cuts off the video controls. If I use a fixed height it cuts off the video controls and still leaves black bars on either side of the video. When I embed the video in the WP Editor it appears on the page normally as it should with the video controls and with no extra container around it. When I use Features to install the video I run into these quirky problems. Is this how it is supposed to be with video in Features? My website is in development in MAMP, so I can't give you an URL. Shouldn't I just be able to embed the video in Features and have it appear as it does when I embed it into the WP Editor? I get all the bells and whistles of Features and I'd rather use it, but why is it displaying so differently?

Share this post


Link to post
Share on other sites
Rob
Though our slider can handle one video, if you're planning more than one, you should consider using a different slider that's designed to handle more than one. As for it cutting things off, I'm unsure how to handle that issue as I've not seen any other topics on this subject. It would help if your site were live, as we could schedule a screen share or view some of the code. Any schedule on that?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
freshlightstudios
No, I'll just have to revisit this issue when it goes live. I know there is a way to make it responsive. For now, I can tell you that I've Added a New Feature and put the video code as iFrame in the "Feature Media HTML (Youtube, Flash etc...)" dialog box. I think the problem is that I'm using iFrame tags. Shouldn't I be using [youtube or whatever] href="" [/youtube or whatever] instead?

Share this post


Link to post
Share on other sites
Rob
I've never recommended the shortcode and haven't had any success embedding video by shortcode. The only code I've had any luck with is the older embed code from Youtube. In fact, our Wiki points out "Insert HTML, Embed Code From YouTube, Flash, etc.." See: http://www.pagelines.com/wiki/How_to_Use_the_Features_Section As I previously pointed out, our slider is really not intended to handle multiple videos. However, it is a jQuery based slider. jQuery doesn't know what's in the slide, however, because it's not a static thing, jQuery doesn't read a shortcode for a video. It requires the specific older embed code in order to work, as shown here: http://screencast.com/t/TFaChu3kegU You cannot use aspect ratio to dynamically resize the video because the video is provided by an external source that provides it in a fixed size. Essentially, you're trying to fit a larger item into a smaller one, and expecting it to resize to fit. It won't. You must use the embed code to select the correct size. This is why you're getting the slides cut off and black backgrounds. Your slides, if using video in any one of them, shouldn't be using aspect ratio as the global setting either. if you do, you'll see problems. If you select the correct size embed (Youtube and Vimeo provide size options), you really shouldn't have any problems because the video will be delivered in a size compatible with your slide height. Unfortunately, the nature of video embeds is such that it doesn't stretch to fit and if it does, the video will appear out of distortion. I believe that when any video is 'sized to fit' the resizing is proportional, and thus you're going to have parts, likely top and bottom, cut off; certainly the bottom. As for the background color, it picks up the site's background color, so try adjusting that via Color Control.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×