Jump to content
Sign in to follow this  
EvtK

Soapboxes looked better on PlatformPro

Recommended Posts

EvtK

Hello, I am rebuilding my site to the platform framework, coming from platform pro. The soapboxes are not so good looking anymore, a pitty!  Anybody some tips to get the Framework soapboxes line up nicely and the same as the Pageline Pro soapboxes? Thanks a bunch!

 

edit: removed links to non-existing sites

Share this post


Link to post
Share on other sites
EvtK

And I know see it gets even worse when the images used in the soapboxes don't have equal sizes..  Please: can this be fixed? Thanks a bunch!

 

Edit: links to non-existing websites removed

Share this post


Link to post
Share on other sites
catrina
Was there any custom CSS you used in PlatformPro that you're now using in PageLines Framework?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
EvtK
Hello Catrina, Yes I use custom CSS on PlatformPro and am using custom CSS on Pagelines Framework. Though the CSS is different because of the changes between Pro and Framework. There was one particular piece of CSS I used for the soapboxes: #soapbox .fboxtitle h3 { font-size: 1.2em; font-weight: bold; line-height: 1.0em; color: #e85f15; } but deleting it from the custom CSS setting doesn't solve the layout issues. Thanks.

Share this post


Link to post
Share on other sites
Rob
Evan, I notice that in the PageLines Framework site, you do not have a media height set. The settings you need are not located in the Boxes section, but in Meta (global) or in the page/post meta settings directly. If you go to [b]Dashboard > PageLines > Meta[/b] in PageLines Framework, there's a tab for SoapBox Meta. There's also a height setting (Soapbox Media) there which is important for making sure the soapboxes line up correctly. If you don't wish them to be set to a maximum height globally, you may also go to the post or page, scroll down to PageLines Meta Settings and set the maximum height there for the Soapbox Media.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
EvtK
thanks for your reply and help. actually the heigt was set on page 'onderzoek', not on 'mensen'. I changed both (100) and (150) but it doesn't help.. In the soapboxes of Pagelines Pro the images where cropped and the boxes lined out on top of the boxes perfectly.

Share this post


Link to post
Share on other sites
Danny
Hi, Can you add this to your custom code please and see if this resolves the issue. [code].fboxgraphic img {overflow: hidden;}[/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
EvtK
Hi Danny, I just added the code to my custom css, but i doesn't same to resolve the issue. Is it not possible to restore the soapboxes in the Framework like they were in PagelinesPro? Thanks

Share this post


Link to post
Share on other sites
catrina
It may be possible, but we have yet to find a solution for it. Please try this CSS instead: [code]div.fboxgraphic img {height: 145px;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
EvtK
Hi Catrina, Well that does help for the 'onderzoek' page.. but not for the 'mensen' page. Still, soapboxes aren't nicely lined out on both pages. I understand this is something you guys at pagelines need to sort out? Thanks for your help!

Share this post


Link to post
Share on other sites
catrina
Can you try deactivating any active plugins to see if the problem persists?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
EvtK

allright.. all active plugins are off.. problem persists...  please tell when I can switch on again :)

Share this post


Link to post
Share on other sites
catrina
You can switch them on again and try this CSS instead: [code]div.fboxgraphic img {height: 145px !important;}[/code] Also, have you checked to see if this problem occurring in multiple browsers (I see it happening on Firefox on Mac, the browser I'm currently using)?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
EvtK
Changed the CSS and activated the plugins again, still no luck. I'm using IE 9 en 8 on my other pc. Both have the problem. Is there anything I can do for you to make this easier to resolve? And I question I have you might can answer: why did it work perfectly in Pagelines Pro and not anymore in Framework? I just can understand that. THanks.

Share this post


Link to post
Share on other sites
catrina
I'm not sure why it wouldn't be working in your install. I haven't seen this issue occur with soapboxes on other sites using Framework. Above I see that you posted the custom CSS you added for soapboxes, but do you have other custom CSS (not just for soapboxes)?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
EvtK
aha.. so this is a unique one :) this is the rest of my custom CSS [code]h1, h1 a, .entry-title h1, .fpost .post-title h1 { font-size: 1.15em; font-weight: bold; } .fpost .entry-title h2, .fpost .post-title h2 { font-size: 0.95em; font-weight: bold; } .fpost .entry_content, .fboxtext, .post-excerpt p, .continue_reading_link, .next-entries, .previous-entries, .widget ul li, .cat-post-item, cat-post-date, .textwidget, dd { font-size: 0.85em; line-height: 1.5em; font-style: normal; } .fxgallery_image { padding: 4px; border: 1px solid #E9E9E9; margin-right: 6px; } .post-meta .c_img { background: none repeat scroll 0 0 #FFFFFF; border: 1px solid #E9E9E9; box-shadow: none; padding: 4px; } #footer a, #footer li h5 a {color: #E85F15;} #footer {color: #000000;} #soapbox .fboxtitle h3 { font-size: 1.2em; font-weight: bold; line-height: 1.0em; color: #e85f15; }[/code]

Share this post


Link to post
Share on other sites
catrina
There doesn't appear to be any other CSS that could be causing the soapboxes to break. In the Soapbox settings, can you try setting the max height (for soapboxes on both pages) to 200px and checking to see if the change takes effect?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Andrew
Rob pulled me on this one, help me understand the original problem w/ the soapboxes and I can patch the extension to fix it. Was the problem just that the heights didn't align? Also, appears we need some spacing on the buttons? Andrew

Share this post


Link to post
Share on other sites
EvtK

Hi Andrew,

Thanks for joining in. In short: I was using PlatformPro and now on Framework. I didn't change anything to my soapboxes, but they come out very ugly on Framework.

I have removed this code suggestion by catrina on my custom CSS

div.fboxgraphic img {height: 145px !important;}

Boxes don't line out and image height isn't adjusted (cropped).

Also, you guys can't see this, but the 'edit' button is appearring on the right side of the box instead of below, next to the 'more' button.

 

Edit: links to non-existing websites removed

Share this post


Link to post
Share on other sites
Rob
I've alerted Andrew again. The "edit" button only appears to you when you're logged in and not to your site visitors. Its alignment next to the "more" button is correct. When you're logged out as admin, you should not see that link, only the "more" link.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
EvtK
Hi range alone. Thanks for your rePly. I know how it works with the edit button. What i wanted t point out is that it doesn't line up next to more button, As it is supposed to! Maybe that info helps you guys!

Share this post


Link to post
Share on other sites
Rob
Could it be that the edit option is wrapping? Since I cant' see it, this is hard to determine. Can you take a snapshot and load it here? Thanks.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Andrew
I'll put fixing Soapboxes on my list for the week, please give me a couple days to take a look, then you'll get an update for it :) After that, let me know if there are remaining issues. we'll get it figured.

Share this post


Link to post
Share on other sites
EvtK
Hi Andrew: thanks for checking out. If you need any help, let me know. I can give you credentials to my site if needed.

Share this post


Link to post
Share on other sites
EvtK
One last thing, i was surfing around the pagelines website (which is great by THE way) and found this page: http://www.pagelines.com/pros/ Would be awesome of THE soapboxes looked like this!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×