Jump to content
Sign in to follow this  
holmeser

Blog Post "Read Full Article" links to home page

Recommended Posts

holmeser

When I click 'Read Full Article' on the Blog summary page, it redirects to the home page rather than going to the full article. How do I correct this? Also, how can I change the URL of a blog post? Thanks, Erin

Share this post


Link to post
Share on other sites
mackenzie
Please post your site's url/link so we may troubleshoot :)

Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites
holmeser
Sorry about that: www.fincalamaya.org Thanks for the response.

Share this post


Link to post
Share on other sites
catrina
First, please try deactivating all active plugins and check to see if the links are working correctly.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
catrina
Are the links still behaving the same way? Are you using the latest version of PageLines?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
holmeser
Yes, the links are still behaving the same way and yes, I am using the latest version of Pagelines. Check out this link: http://www.fincalamaya.org/flm-in-the-news/ Click one of the Read Full Article links. As you will see, it redirects to the home page.

Share this post


Link to post
Share on other sites
catrina
Are your Permalinks using a custom structure? If so, please reset it to the default and check the links again.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Rob
To complement what Catrina said, you should CHMOD the .htaccess file in your installation to 777, then go to Dashboard > Settings > Permalinks and save your settings without changing them. This should update links throughout the site to match your permalink structure. It's important NOT TO CHANGE the settings. It will likely fix the links, which don't appear to be picking up the permalinks.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
holmeser
Yes, the permalinks are custom structure. I set them up that way so that I could optimize for SEO. But, if it's not going to work, I would rather have them function. I am sorry, but am not extremely technical. Can you please clarify "CHMOD the .htaccess file to 777"? How do I do that? Thanks for your help! Erin

Share this post


Link to post
Share on other sites
Rob
Erin, usually this is done by FTP, Shell access or, if your host provides tools like cPanel or Plesk, through those tools. You should ask your hosting company for assistance in setting the CHMOD to 777 so that you can update the permalinks. They should be able to assist you with that.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
holmeser
Okay, thanks. My hosting company does have cPanel, so I will ask them for help. - Erin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×