Jump to content
Sign in to follow this  
Jackey

jQuery error Kenburner Slider Section

Recommended Posts

Jackey

I have the Kenburner Slider installed on my site, and it produces an error in the latest versions of Safari (mac), Chrome (mac) and Firefox (mac):

jquery.kslider-min.js:2
	Object
	bgMargin: 10
	cd: 10
	height: 350
	loaded: 1
	maxitem: 2
	padbottom: 25
	padleft: 0
	padright: 0
	padtop: 0
	pauseOnRollOverMain: "off"
	savedTimer: 15
	thumbStyle: "bullet"
	timer: 150
	touchenabled: "on"
	width: 900
	__proto__: Object
	jquery.js:2TypeError: 'undefined' is not an object (evaluating 'a.length')

IE8 quits on this page displaying no slider at all. Can anyone reproduce this?

Share this post


Link to post
Share on other sites
Rob
Jackey, I suspect this to be a widening problem that first manifest with sliders and Chrome for Mac. Everything looks great on a Windows based machine.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Jackey
Already responded to Simon about that, I had my suspicions as well... his fix did not provide a solution for this though. Checked on IE8 and IE9 on windows today, and both browsers quit displaying half way the page, so the slider does not even show. Chrome and Firefox are ok on windows.

Share this post


Link to post
Share on other sites
Rob
Jackey, I'll bring this to Simon's attention as soon as I see him.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Jackey
Thanks, however I don't think it is browser related since all browsers detect the "problem" code. Each browser seems to handle it differently... safari, chrome and firefox still render the page with the slider, and reporting the error, versus IE8 and IE9 that quit rendering the page as soon as the error occurs.

Share this post


Link to post
Share on other sites
Simon
Please report the issue here http://www.pagelines.com/tracking/kenburnerslider This is NOT related to the chrome/features problem with the main slider.

Share this post


Link to post
Share on other sites
Jackey
Okay, done... This however does does not give much confidence: QA responsible: noone ;)

Share this post


Link to post
Share on other sites
Simon
Well it is a 3rd party section ;)

Share this post


Link to post
Share on other sites
Jackey
Thanks Tmeister! Fixed the problem it caused in IE8 and IE9, by releasing Kenburner Slider 1.1. However, the slider still generates an error in jquery.js: [code]TypeError: 'undefined' is not an object (evaluating 'a.length')[/code] Issued this on Pagelines Track.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×