Jump to content
Sign in to follow this  
willowtee

Different Background Image on the Home Page

Recommended Posts

willowtee

Hi I've read all the posts regarding this in the forum, and unfortunately I'm still having difficulty! I'm wanting to set a different background image for this home page - http://zucchini-clan.com/home Currently I have this css, to set an alternative bg, but it isn't changing - body.page-id-150{background-image: url(http://zucchini-clan.com/wp-content/uploads/2012/01/bgTile.jpg'); } Any help would be much appreciated Thanks T

Share this post


Link to post
Share on other sites
Rob
You seem to be missing a ' following url( in your CSS. It should be: [code]body.page-id-150 {background-image:url('http://zucchini-clan.com/wp-content/uploads/2012/01/bgTile.jpg');}[/code]

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
willowtee
Thanks for picking that up. I've now corrected, and it still doesn't work? Any other ideas?

Share this post


Link to post
Share on other sites
Jenny
Where are you entering this code? It isn't even rendering in your CSS. Could you please paste the entire snippet of code. You may have a CSS error in it.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
willowtee
I had pasted the css into platformpro > custom css originally I then tried placing it in the main stylesheet with a small amount of success....I can now see a little line of the desired bg at the top and bottom of the page, but the bg image im trying to over ride is still visible. http://zucchini-clan.com/home I guess this helps clarify my original question - how can I set up my background on the home page to over ride the bg set in platform pro options? Thanks for your help on this

Share this post


Link to post
Share on other sites
willowtee
And here all the css I have pasted in the custom code section (minus the body.page-id-150 {background-image:url.... which is now in the main stylesheet) #primary-nav li a { text-transform: lowercase; font-family: HartingPlain, courier, serif; font-size: 22px; } p {font-family: HartingPlain, courier, serif; font-size: 19px; } H1{font-family: HartingPlain, courier, serif; font-size: 48px; } H1#wildlife {font-family: HartingPlain, courier, serif; font-size: 44px; color: #e06609; } H1#musicFor {font-family: HartingPlain, courier, serif; font-size: 62px; color: #e06609; } H2{font-family: HartingPlain, courier, serif; font-size: 43px; letter-spacing: -2px; } H3{font-family: HartingPlain, courier, serif; font-size: 24px; color:#e06609; } img.mainlogo-img { margin: -26px 0px -60px 0px; } img#home { margin: -40px 0px 0px 0px; } ul#menu-main li { float:right ; } a#readings{font-family: HartingPlain, courier, serif; font-size: 58px; } a#contact{font-family: HartingPlain, courier, serif; font-size: 52px; } img#cover{ margin:12px; border:2px solid #e06609;

Share this post


Link to post
Share on other sites
catrina
You can use this code to add a background image to the homepage: [code]body.home {background-image: url('http://imageurl');}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
willowtee
Thanks for the suggestion - but it doesn't work sadly

Share this post


Link to post
Share on other sites
willowtee
I put it in the main stylesheet, and have since tried popping it in platformpro> custom css, and that didn't work Again I can see it, its the thin green textured strips at top and bottom of page, but the white paper background which I've set in the platform pro> design control is still the main bg image Thanks

Share this post


Link to post
Share on other sites
Danny
Hi WillowTree, Please remove the current code you have and replace it with this please: [code].page-id-150 #page { background-image: url('http://zucchini-clan.com/wp-content/uploads/2012/01/bgTile.jpg'); background-color: transparent !important; }[/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
willowtee
Worked a treat!!! Thanks Danny, its much appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×