Jump to content
Sign in to follow this  
diretornak

How to speed up Cufon load time?

Recommended Posts

diretornak    2
diretornak

Hey guys! I was wondering how i could speed up the cufon load times. What happens is that, whenever i load the site it takes a long time (2-3 secs) for the cufon to kick in. I am not overusing it, so thats not the issue. The only places im using cufon is in the home (for navigation and box titles) and in the blog page (for post titles). Any help will be greatly appreciated. =D Cheers!

Share this post


Link to post
Share on other sites
Jenny    33
Jenny
I assume that is because it is accessing the font externally. I recommend visiting this link and contacting them for assistance: http://cufon.shoqolate.com/generate/

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
diretornak    2
diretornak
I am hosting the font in my own server =[

Share this post


Link to post
Share on other sites
Jenny    33
Jenny
Hmm that is odd. Have you tried contacting your web host to see if they are blocking the file in some way?

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
diretornak    2
diretornak
I guess i'll do that...

Share this post


Link to post
Share on other sites
diretornak    2
diretornak
Apparently there is nothing blocking the file in any way... maybe its just loading other stuff before the font? I havent added any scripts to the header or footer, so its weird =[

Share this post


Link to post
Share on other sites
catrina    103
catrina
I've seen Cufon load this slow before and I'm not sure why it is. The info provided here may provide some helpful insight: http://stackoverflow.com/questions/2383244/what-are-some-ways-to-speed-up-cufons-load-time

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
diretornak    2
diretornak
Thanks a lot i will read that post =D

Share this post


Link to post
Share on other sites
jomafilms    0
jomafilms
I was having this problem too with a flash of the old text before Cufon loaded. The below solution seems to be working for me now. I'll use h1.entry-title here as an example: Add this to CSS: h1.entry-title {visibility: hidden;} then in PageLines Settings / Custom Code / Footer Scripts add: I'm thinking this works because the PL cufon code is wrapped in jQuery(document).ready and most of the site loaded before the Cufon replacement. Now the text I'm replacing becomes visible after the Cufon script runs. Of course, if javascript isn't active on the browser, those titles won't be visible.

Share this post


Link to post
Share on other sites
diretornak    2
diretornak
Sweet! Thats exactly what I needed! Makes perfect sense, but I just didnt think about doing it =D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×