Jump to content

Archived

This topic is now archived and is closed to further replies.

minasm

Carousel roatation lightbox problem

Recommended Posts

minasm    1
minasm

Hello there, There seems to be problem with Carousel. After rotating images does not show up in a lightbox. I thought it was in the second rotate loop but it sometimes happens in the first rotate. Any idea how to solve this or any cause of the problem? Thank you

  • Like 1

Share this post


Link to post
Share on other sites
catrina    103
catrina
Did this problem begin recently after having carousel for awhile or was it behaving that way when you first implemented the carousel?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
minasm    1
minasm
Had this problem with 2.0.1 and still have it. I am using like 20 of this elements in different pages, some carousels have same sized images, thought images might cause the problem but seems not.

Share this post


Link to post
Share on other sites
catrina    103
catrina
Have you already tried deactivating your active plugins to see if the issue disappears? You may also want to check to make sure that your plugins are compatible with the version of WordPress you're using.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
minasm    1
minasm
Yes, I will give it a try. Though NextGen is used by the Carousel, so not sure if i should disable it :) Now, disabled everything. This time my carousel was empty. Enabling only nextgen did not do the trick. fyi

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Would it be possible for you to post a link to your website please.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
minasm    1
minasm
Here is the link: http://goo.gl/xZes7 just try rotating it and click on the images. Thank you.

Share this post


Link to post
Share on other sites
catrina    103
catrina
I'm experiencing the issue for all images in the Carousel. Are you using the latest version of WordPress?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
minasm    1
minasm
Yes Catrina, it is 3.3.1. Btw, I gave it another try disabling all plugins other than NextGen, did not workout.

Share this post


Link to post
Share on other sites
Rob    547
Rob
Hi, I looked at your site just moments ago and see you definitely have a problem. I don't know why this problem is happening but you may wish to contact NextGen via http://alexrabe.de/wordpress-plugins/

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
minasm    1
minasm
@rangelone thank you for cheking it. I will try to feed Pagelines carousel from flickr or something. So that I can be more specific, I guess :) Cause using slideshows, images etc from NextGen shortcode seems to operate fine :S

Share this post


Link to post
Share on other sites
Jenny    33
Jenny
I have never used the carousel for NextGen images personally, but let us know how your other angles work out. :)

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
minasm    1
minasm
@simple_mama how did you populate the carousel then? I am trying to use a plugin named JJ NextGen JQuery Carousel which I dont like at all, plus still could not figured it out. thank you.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Hi, I have just this moment created a NextGen Gallery and the Lightbox worked perfectly. Have you made any changes to the NextGen options at all ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
minasm    1
minasm
Thank you for your effort Danny, I deleted nextgen-gallery under the plugins via FTP and downloaded a fresh one and uploaded it. Just wanted to make sure. Now I have a fully clear nextgen-gallery but still the problem continues. I will install Pagelines to another blog and will experiment I guess:( Btw posted to wordpress forums but no one said anything yet...

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
I have just revisited your website and the lightbox effect is now working, what was the issue ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
minasm    1
minasm
Dear Danny :) I even was shocked when I read your comment hehe Yes it works but just try cycling right or left one or two times then give another try. That's my problem. If I don't cycle there is no problem at all :)

Share this post


Link to post
Share on other sites
minasm    1
minasm
Here we go, In this site I have installed Pagelines w/ latest version, http://goo.gl/xaOKj The same problem goes here as well. I used the same plugins (total of 7) At first it looked ok but there is a picture. A white and two gray tones wallpaper image. When I click it, it will never show in a lightbox. I will add another carousel without that image and tell you the result. I wonder if the size matters here... Ok I created another carousel with all smaller sized images.http://goo.gl/CpVjN but when page loads its all good. Rotating the carousel one or twice causes the problem again.

Share this post


Link to post
Share on other sites
catrina    103
catrina
When I cycle left and click on the thumbnails the problem occurs. When I cycle right and click on the thumbnails, it doesn't happen. I'm not sure what could be causing abnormal behavior for different people. Does the problem occur after refreshing the page several times?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
minasm    1
minasm
Hey catrina :) Yes, it still fails refreshing a few times. Third try http://goo.gl/S1tO2 My settings are here: Total Carousel Items : 4 Displayed Carousel Items: 3 Scrolled Carousel Items: 2 Animation Speed of Scroll (milliseconds): 40 Carousel Image/Link Mode (Carousel Page Template): NextGen Gallery Carousel Image Dimensions (Posts Mode Only) tried both blank and some values plus I am not using carousels on posts. these are only pages. NextGen Gallery ID For Carousel (Carousel Page Template / NextGen Mode) giving the id of the gallery. I am willing to share my wordpress info for the testing site I am sharing the links. Maybe you can figure it out the but. Tried this on two different sites hosted on two different servers. Using only NextGen, Pagelines Customize and Pagelines Sections plugins. Another weird issue is that when page loads and I click on a thumb it opens in lightbox, but after page loads and I cycle a few times then click on the same image it does not open in it...:( Note: Tested on Chrome, IE, Firefox and Safari on PC and MAC (MAC didnt have IE :))

Share this post


Link to post
Share on other sites
minasm    1
minasm
There is a comment on wordpress forums A user named Felix commented on the problem; [quote]I think it's because of the behaviour of the carousel arrows. I noticed that the pics on your carousel have this following id pattern: ngg-image-65 ngg-image-66 ngg-image-67 and so on. Well, when you click the carousel arrows, it CREATES a new li element, and somehow, it uses an id that it's already being used on another picture. I noticed this when i left the firebug window open while clicking on the arrows. I don't have the time right now to check on some of your js code (specially cause i'm still a js beginner, the shutter thingy i fixed was basically pure luck added with some logic.) but i suggest you trying to NOT let the arrows create new elements. Put them straight on the HTML, and the arrows would just MOVE your view, or maybe the elements itselves, after all, what's important it's the carousel effect being shown, not how it was done. Having your pics straight into the HTML open you to some new improvements: - You can store them in a database and print using a loop. - You can also create an User-friendly interface to add new pics.[/quote] Hope this leads somewhere :)

Share this post


Link to post
Share on other sites
Rob    547
Rob
Hi, I use the feature images directly from the posts and include a full size picture in my posts. I'm not sure why your problem is happening, but I suspect there's some type of conflict that prevents the lightbox from opening, even if the image opens to an image view. I can imagine you wanted something different. Really, the carousel is intended as a means to entice visitors to your posts, not to display images for image viewing. However, there are many which have been designed with built in lightbox view. Have you searched for one? Start at http://www.wordpress.org/extend/plugins

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
minasm    1
minasm
rangelone, I agree but I need to make that carousel work as a image gallery there:D its not that weird, is it? I tried JJ NextGen JQuery Carousel but still did not make it work:D its a bit messy for me:( Pagelines carousels' look and feel is far more enough for me:D

Share this post


Link to post
Share on other sites
catrina    103
catrina
Have you tried looking for other possible carousels here?: http://wordpress.org/extend/plugins/search.php?q=jquery+carousel

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
minasm    1
minasm
Seems no code update will come for carousel, that why I am trying other plugins as I told one post earlier:) Thanx tho..

Share this post


Link to post
Share on other sites

×