Jump to content
Sign in to follow this  
msaizan

Possible Bug - Sidebars -Pagelines Framework 2.1.1, Base 1.0.2

Recommended Posts

msaizan

My sidebars just rearranged themselves. I was doing some ordinary posting...then stopped to take a break - was off site for about a half hour - and when I started back to post, i saw that the sidebars had auto-magically re-arranged themselves. The elements in the Universal Sidebar had moved to the more foot sidebars - the primary sidebar emptied..some of the elements have disappeared - some went to the universal sidebar and more foot sidebars etc. I have got the site in maintenance mode and I am in process of trying to assess where things went and just exactly what I have lost, but I thought I would let you all know what's going on... I can provide a link to the site but it is in maintenance mode - because the site is totally discombobulated - if any of of the PL support team wants to have a look see I will have to email you the login... gulfcoastrising.net/news/

Share this post


Link to post
Share on other sites
catrina
Did you publish the post and then continue editing it? Hmmm, it's difficult to assess what could be the cause if the Dashboard was just sitting there. Do you have any active plugins you can deactivate?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
msaizan
This problem has nothing to do with posts. The issue is that my sidebars auto-magically rearranged themselves...and I wasn't working in the widget area or in Pagelines settings and/or with anything that had to do with sidebars at the time... The only reason I mentioned posting is just to let you all know what was happening when the sidebars disappeared. The main point was to let you all know that i wasn't in the widget area at all - I was just posting - and when I saved and viewed the post I noticed the primary sidebar was showing up on the page as empty and the items that were formerly in the primary sidebar had moved to the universal sidebar - and it impacted every page and post on the site... not just the post i was working in...My person issue is fixed for now - I put the sidebars back together as they were supposed to be so there is no problem that I need help with now - i am more or less reporting that there may be a problem or bug with the sidebars - Might be something a PL developer needs to look into it..

Share this post


Link to post
Share on other sites
Simon
Under 'Advanced' tab do you have 'Enable sidebar priorities?' enabled?

Share this post


Link to post
Share on other sites
msaizan
Hi ya Simon - yes I do have 'enable sidebar priorities" enabled...

Share this post


Link to post
Share on other sites
Simon
That setting would have re-ordered them, Primary..secondary etc. But re-ordering them does not move the widgets as well.

Share this post


Link to post
Share on other sites
travelcafe
I encountered the same problem as msaizan when I selected the 'enable sidebar priorities'. (Unticking the box returned the sidebars to normal). However, I am a bit concerned about what will happen in future because the More Info section on that feature points out that "This will become default by 2.2". I have quite a bit going on in my sidebars, using widget logic etc, and I wouldn't be too keen on having to nut all that out again. So, Is it a 'bug' causing sidebars to rearrange their content when I select 'enable sidebar priorities', or should I just select that option now (and re-do all the work) before I go too far?

Share this post


Link to post
Share on other sites
msaizan
'Enable sidebar priorities' has been ticked since the upgrade to 2.1. Of course my sidebars were discombobulated then - when i first ticked to enable...and I expected that to happen...But what happened today has nothing to do with that. The sidebars were already enabled - and had been for over a week or so - when they auto-magically rearranged themselves today... As with @travelcafe....i have the same concerns. I too have a lot going on in the sidebars - I am using widget logic as well - and a discombobulation of the sidebars takes my site down. I had to go into maintenance mode while I straightened it out - the bigger concern was that the widgets had disappeared - that's hours of building and configuring - if they were to go 'poof' permanently.. in that case, i would be down for hours and i would have a good bit of work ahead of me to rebuild all the sidebars. it would be a lot of work...that's why I am taking this time to report this...

Share this post


Link to post
Share on other sites
msaizan
oh, simon - since we are on the subject...when i enabled priorities right after the upgrade - for the first time - it did rearrange the widgets in the sidebars as well...some were moved to the inactive widget area - but some ended up in completely different places - like widgets that were originally installed in morefoot were in the universal sidebar...A similar thing happened today - but this time I wasn't doing anything with sidebars when it happened.

Share this post


Link to post
Share on other sites
Simon
Widgets do not move around by themselves. If you change theme, or change the way they are ordered then they will change. If you have a way to reproduce this behavior then let me know.

Share this post


Link to post
Share on other sites
travelcafe
I can assure you pross, that is exactly what does happen. I would be quite happy to provide you with a temporary admin password so that you can select 'enable sidebar priorities' yourself and see what results... which is widgets spread all over the place. PM me if you would like a temporary login and password to test.

Share this post


Link to post
Share on other sites
Simon
But enabling it WILL reorder them, thats the point! You enable it, it re-orders them like PlatformPro was ordered. The widgets will not stay where you set them before you tick reorder.

Share this post


Link to post
Share on other sites
travelcafe
You have lost me now. What [i]is[/i] the point? I was not a PlatformPro user, so I don't understand how that worked. But I have spent a good deal of time setting up my sidebars. When I tried the 'Enable sidebar priorities' box then, yes, the order of the sidebars in the widget area changed. But Widgets I had set up in the Tertiary sidebar, for example, ended up in the secondary sidebar, or the footer sidebar. All over the place. What is the point of that? Please advise.

Share this post


Link to post
Share on other sites
Simon
Ok I'll explain one lat time. Wordpress stores the sidebars in numerical order, the order they are registered. PlatformPro loaded the sidebars in a different order because of the way the files were structured, it dictated the order PHP found them and the framework registered them to wordpress. When 2.0 was in development we restructured the folders and PHP loaded them in a different order. This caused sidebar-1 ( as wordpress stores it ) to be different. So in 2.1 we added the priority system so users can have the order the same as PlatformPro. So its purely optional, whatever works for you, if your upgrading from PlatformPro, enable the priority system and the sidebars will be loaded in the same order, its as simple as that.

Share this post


Link to post
Share on other sites
travelcafe
Thanks for explaining it further, @pross. But the reason I have stopped working on my sidebars is because of the 'More Info' message beside the Enable Priorities checkbox at Pagelines > Settings > Advanced i.e. [quote]Enable new sidebar loading system With this enabled sidebars will be loaded: Primary, Secondary, Tertiary etc. ( This will become default by 2.2 )[/quote] [img]http://travelcafe.co/wp-content/uploads/2012/02/what_is_meant_by_default.png[/img] I am just concerned that everything will get scrambled with 2.2, and frankly, I don't really have time at this point to rework my sidebar vs. widget locations. (But if the sidebar priorities are going to be forced on me with 2.2, I guess I should work on them now). So when the info says "Default", does than mean it will still be optional? Please confirm. Cheers.

Share this post


Link to post
Share on other sites
Simon
Well, maybe we should just leave the order as is. File a bug to remind us ;) http://pagelines.com/tracking/pagelinesframework

Share this post


Link to post
Share on other sites
msaizan
Widgets do not move around by themselves welpers - that's what happened - they moved around by themselves...i have never heard or seen it happen before either...and it had nothing to do with enable priorities...because i had ticked that a month ago...wasn't changing themes or moving any widgets around. I was posting content in the wysiwyg editor - wasn't even in the widgets area. It hasn't happened since - and i have no way to reproduce it for ya - but if it happens again will let ya know..

Share this post


Link to post
Share on other sites
msaizan
It happened again. Sidebars auto-magically rearranged themselves... This morning, got up to post and saw that the sidebars were emptied and the widgets were thrown into the inactive area - THANK GOODNESS they were thrown to the inactive area because i was able to just slide them back to where they belonged... I wasnt' doing anything out of the ordinary. The enabled sidebar priorities is still ticked - wasn't removed or anything like that...the widgets just went poof out of the sidebars and moved to the inactive area We either have a possible bug here or there is a ghost or a poltergeist doing stuff with my website. (that's a joke btw)...

Share this post


Link to post
Share on other sites
Simon
@msaizan can you try the following: open includes/actions.site.php line 117 [code]add_action( 'init', 'pagelines_add_sidebars', 999 );[/code] Change 999 to 1

Share this post


Link to post
Share on other sites
msaizan
done. changed line 117 from 999 to 1.

Share this post


Link to post
Share on other sites
travelcafe
OMG! A whole bunch of widgets in my sidebars have varnished! Hours and hours of work setting up customized sidebar content, just GONE! What is going on here? Please help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×