Jump to content
Sign in to follow this  
jbrouwer

explorer 8 and 9 issues

Recommended Posts

jbrouwer

Hi, Just discovered some issues with explorer 8. My site (www.pepperbase.com) looks fine in Chrome and Firefox, but in ie8 the magazine layout breaks down. Deactivating plugins didn't help. I also enabled the google ie compatability script. I am using pagelines 2.1. Any other suggestions? Further, in ie8 and in ie9 the Recently active members widget of Buddypress is breaking down. Did somebody had the same problem? Thanks!

Share this post


Link to post
Share on other sites
Danny
HI, Would it be possible if its not to much trouble for you to take some screenshots and post them here please. Some of us don't have IE installed.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jbrouwer
ie8: [img]http://www.pepperbase.com/wp-content/uploads/ie8.png[/img] ie8 shot2 [img]http://www.pepperbase.com/wp-content/uploads/ie8-2.png[/img] ie9 [img]http://www.pepperbase.com/wp-content/uploads/ie9.png[/img]

Share this post


Link to post
Share on other sites
Jackey
I have a IE8 test machine setup. I see that the grey background of the sidebar does not show in IE8. Transition is not supported with IE8: [code]#column-wrap, #sidebar-wrap, .clip, #column-main, #sidebar1, .content, #page { transition: all .2s linear; -o-transition: all .2s linear; -moz-transition: all .2s linear; -webkit-transition: all .2s linear; } [/code] Could this be it?

Share this post


Link to post
Share on other sites
Jackey
Sorry, see what you mean now... I think the layout is breaking down because all images are rendered full-size in IE8. This is something I already mentioned a few months back. It seems that IE8 can't handle [code]
  • Share this post


    Link to post
    Share on other sites
    jbrouwer
    Did not change a thing. Any thoughts on the avatars? I've read that multiple columns is not supported by ie8 at all...

    Share this post


    Link to post
    Share on other sites
    jbrouwer
    I am not using ie8 at all, but 25% of my viewers are...

    Share this post


    Link to post
    Share on other sites
    Jackey
    What have you changed... it looks ok now.. Only the buddypress icon placeholders are a bit big

    Share this post


    Link to post
    Share on other sites
    Jackey
    As a patch maybe you can scale this icon down to 50x50 by hand: [code]http://www.pepperbase.com/wp-content/plugins/buddypress/bp-core/images/mystery-man.jpg[/code] It will probably fix your bp sidebar, but I can't say it won't change any bp pages.

    Share this post


    Link to post
    Share on other sites
    Jackey
    May I ask what you did to restore the magazine layout in IE8?

    Share this post


    Link to post
    Share on other sites
    jbrouwer
    This fixed the avatar problem in the sidebar in ie8 and ie9: [quote].item-avatar{ heigth: 50px; width: 50px; }[/quote] I didn't fix the magazine layout mode in ie8. I am still having one column...

    Share this post


    Link to post
    Share on other sites
    Jackey
    Aha... clever! I see, it is broken again, It was okay in IE8 at 3:47PM, I'm sure! It even showed the grey borders around the panels... (square though, because IE8 can't handle corners)

    Share this post


    Link to post
    Share on other sites
    Jackey
    You now and then have a error on your page: [code]TypeError: 'null' is not an object (evaluating 'navigator.appVersion.match(/MSIE (d.d)/)[1]') script.cycle.js:25[cycle] terminating; too few slides: 1[/code] Can you try adding a second slider to your Feature Slider. Or maybe disable the transition.

    Share this post


    Link to post
    Share on other sites
    jbrouwer
    Thanks. I've only one sheet for the slider. I have not seen this error myself (ever). Is it still there?

    Share this post


    Link to post
    Share on other sites
    Jackey
    No errors now... layout still broken in IE8. Have you tried disabling your W3 Total Cache plugin, to see if that restores the layout in IE8? (just checking)

    Share this post


    Link to post
    Share on other sites
    jbrouwer
    Thanks for the suggestion! It has something to do with the minify settings.

    Share this post


    Link to post
    Share on other sites
    jbrouwer
    The only item remaining is the buddybar in ie8. I believe it has something to do with the css order of the color and the background...

    Share this post


    Link to post
    Share on other sites
    Jackey
    Hence my suggestion to disable W3 Total Cache: [code][/code] I see the buddy bar is transparent, maybe this helps: [code]#wp-admin-bar { background: rgba(0, 0, 0, .7); }[/code] [code].IE8 #wp-admin-bar { background: black; }[/code] You need to install [b]Browser Specific CSS[/b] from the Pagelines Store to do this.

    Share this post


    Link to post
    Share on other sites
    Rob
    I am unsure that anything on PageLines will work perfectly in IE8 because IE did not utilize the HTML5 or CSS3 modes. That may be partly the reason for IE9 having issues. I understand they're working on IE11 already. That one's likely to be more effective with PageLines.

    Former PageLines Moderator, Food Expert and Raconteur

    Share this post


    Link to post
    Share on other sites
    jbrouwer
    @jackey I prefer to keep using w3tc to improve loading times. Manually selecting which files w3tc should minify did the trick. I will try out your css suggestion. Thanks.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    ×