Jump to content
Sign in to follow this  
dnnyboy

Meta Settings Not Loading - WPML - PageLines

Recommended Posts

dnnyboy

I'm working upgrading our site from PlatFormPro 1.5.3 to PageLines Framework 2.1. But something's causing the Meta Settings page not to function properly. When I click it, it takes forever to load and doesn't load properly. It seems to be related to the WPML (String Translation) plugin, as disabling this appears to fix the issue. Any ideas on what I might do? Obviously, I depend on the WPML plugin, so I can't disable it. This is what it looks like: meta.png

Share this post


Link to post
Share on other sites
Danny
Hi, I have never used WPML before, but is it possible to disable the plug-in for the Wordpress Admin Dashboard only ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dnnyboy
I don't think so. Also, I use WMPL to allow for language-specific feature-sets, etc. and this requires the plugin to work on admin values also (I believe). For instance, I choose my posts page feature set in Meta Setting -> Blog Page -> Features -> Select Feature Set To Show - and then I use WPML string translation to provide language-specific version of this setting ([pagelines-special][posts]feature_set)...

Share this post


Link to post
Share on other sites
dnnyboy
Also, if you're interested: http://wpml.org/documentation/theme-compatibility/go-global-program/

Share this post


Link to post
Share on other sites
Andrew
I'd say the best course of action would be to take this up w/ this folks at WPML. I've heard they do a good job of support. Tried that? Andrew

Share this post


Link to post
Share on other sites
dnnyboy
@catrina - yes, the problem only occurs with the WPML String Translation plugin enabled. I've tried disabling all and enabling only WPML, and the problem persists. @arpowers - I haven't yet, no. I will try though. My only problem is that I don't really know what to tell them...

Share this post


Link to post
Share on other sites
dnnyboy
FYI, the folks at WMPL advised me to enable debugging and I found this error when trying to load the Meta Setting page: Fatal error: Maximum execution time of 30 seconds exceeded in /wp-includes/functions.php on line 342 if ( defined( 'WP_SETUP_CONFIG' ) ) return false;

Share this post


Link to post
Share on other sites
catrina
There is something wrong in the functions.php file. I Googled the error to see if I can find anything but I only found these topics: http://wordpress.org/support/topic/fatal-error-maximum-execution-time-of-30-seconds and http://wordpress.org/support/topic/keep-getting-fatal-error-on-linemax-execution-time-of-30-seconds

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dnnyboy
So, it seems that something is causing the Meta Settings page render very slowly. If I increase the php setting "max_input_time" to 120, I can get the page to load. Mysql is not the culprit, as only about 60 queries are executed in ~100ms. PHP, however, takes ~110 seconds to finish rendering the page. WPML tells me that the String Translation will look for strings to translate and that this might take time. Now, I tried a clean install (WP 3.3.1, PageLines Framework 2.1 and WPML) and in this setup the page loads fine in no time. So can anybody help me figure out what happens during the rendering of /wp-admin/admin.php?page=pagelines_special that would be minimal at a clean install and take up to 2 minutes on my production system? Would number of posts, pages, other custom post types, etc. affect what happens? Thanks.

Share this post


Link to post
Share on other sites
catrina
[code]Would number of posts, pages, other custom post types, etc. affect what happens?[/code] I'm not certain that this would be the cause. Do you utilize a lot of your Special settings?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dnnyboy
Not at all. Of course also because the page won't load properly.

Share this post


Link to post
Share on other sites
Rob
That functions.php is actually Wordpress, not PageLines'. Have you taken this up with Wordpress or searched their codex further?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dnnyboy
@rangelone, I have not. The issue only occurs with the WPML plugin enabled on the PageLines Framework. Any ideas? This issue is keeping me from making the switch from PlatformPro :(

Share this post


Link to post
Share on other sites
dnnyboy
@catrina, that wouldn't really make sense as the problem only occurs on the PageLines Meta Settings page?

Share this post


Link to post
Share on other sites
catrina
I was just wondering if Twenty Ten would have an issue with the WPML plugin. Have you tried getting in touch with the WPML creator about the issue?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dnnyboy
I'm trying to get help from WPML as well, but right now I feel stuck :( And until I get this solved, I can't make the upgrade from PlatformPro to PageLines Framework...

Share this post


Link to post
Share on other sites
Rob
Catrina's correct. Please activate the Twenty Ten theme and refresh your browser or clear any cache to make sure this is related specifically to WPML's relationship with PageLines or to determine if it's a problem with the plugin itself. Looking at the page for that plugin, it appears it hasn't been updated in a bit http://wpml.org/documentation/support/translation-for-texts-by-other-plugins-and-themes/ I also note that they have not tested for PageLines products at all. I apologize that you're in this position but I'm unsure how to assist as the functions.php you mentioned earlier isn't ours. Actually, PageLines has more translation advancements than PlatformPro but I suspect you might have to edit PO files with POEdit and that this plugin might not function properly.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dnnyboy
@rangelone, I have activated Twenty Ten and it works fine. I don't know what I would do to try to replicate the error I get with PageLines, as the Meta Settings page obviously isn't available using Twenty Ten. I'm at running the latest version of WPML released on February 9th, 2012. It would great if someone from Pagelines could work with WPML to ensure compatibility (http://wpml.org/documentation/theme-compatibility/go-global-program/).

Share this post


Link to post
Share on other sites
Rob
I will bring this to our developer's attention. Thanks and again I'm sorry there seems to be a problem.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dnnyboy
Could someone please help me investigate this issue a bit further? I'm really stuck and can't make the upgrade to the Pagelines Framwork :(

Share this post


Link to post
Share on other sites
catrina
This was already marked for developer's attention, but you can add the WPML plugin to this list to ensure that its compatibility is checked: http://www.pagelines.com/forum/discussion/18474/plugin-compatibility-list

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dnnyboy
@catrina, Funny thing. One of the mentioned plugins on the incompatibility page has the exact same issue as I'm having with WPML (messes up the layout of Meta Settings)...

Share this post


Link to post
Share on other sites
Danny
If your Meta Settings layout messes up, this is due to the plug-in using its CSS on pages its not supposed to, this is something you would have to bring to the attention of the developer of the plug-in. Rangelone has already brought this to the attention of the developers.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×