Jump to content
Sign in to follow this  
salesdigitalheavenscouk

Station pro 3 and wordpress 3.0 menu

Recommended Posts

salesdigitalheavenscouk

When i upgraded wordpress and station pro 3 i get this error: The current theme does not natively support menus, but you can use the ???Custom Menu??? widget to add any menus you create here to the theme??™s sidebar. The option to use wordpress 3.0 menus ticked in the theme options. Does this feature work with station pro 3 as i really wanted to make use of the new menus?

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

I also can't seem to find where i can change the background to an image, im sure in version 2 there was an option for it.

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

Ive managed to fix this problem now, the wordpress 3.0 menu and the background image are now working :)

Share this post


Link to post
Share on other sites
Andrew

Well that was easy... what wasn't working as expected?

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

The new menu system did work. I added this code to the functions.php register_nav_menus( array( 'primary' => __( 'Primary Navigation' ),) ); I have no idea what im doing so im suprised it worked lol

Share this post


Link to post
Share on other sites
Andrew

we had it working prior to the official 3.0 release, but it looks like they changed some stuff right at the last minute...

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

Sounds like it, this is working at the moment but if i remove the search from the nav menu the buttuns can't use the extra space. Ive enabled the search for now to hide the empty space.

Share this post


Link to post
Share on other sites
bryan-hadaway

Would you like to not have search there and hide the empty space? Can you please provide a link. Thanks, Bryan

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

When the search option is on the buttons are pushed down to another level because there are too many to fit on the manu See image 1. menu1.jpg If i remove the search option the menu remains the same, Possible bug maybe? menu2.jpg

Share this post


Link to post
Share on other sites
bryan-hadaway

Try adding this to your Custom CSS:

#nav{width:960px}

If that almost works, but not quite try decreasing or increasing 960. Thanks, Bryan

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

That made the black bar wider but the buttons stay the same. The old method works fine, its only this new wordpress 3.0 menu that has this bug.

Share this post


Link to post
Share on other sites
bryan-hadaway

Yeah, WordPress 3.0 is so new I haven't familiarized myself with it yet, I'm sure the developers will be updating the themes to fix these kind of things soon. Thanks, Bryan

Share this post


Link to post
Share on other sites
salesdigitalheavenscouk

Yeah, always bugs with new versions of wordpress. What ive dont is put the one button in another as a sub menu for now and active the search option to hide it. ;) Looks good lmao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×