Jump to content
Sign in to follow this  
pehja

Vanilla integration Error

Recommended Posts

pehja

I have tried to install and integrate Vanilla into my site. And I have run into problems. When I am going to visit my site from Vanilla it looks like this. Skarmavbild%202012-01-26%20kl.%2020.17.21.jpg I don't no where to put the files.. Tryed to se if I could find a post on the forum about this, but I didn??t. So if anyone can help please.


Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
Rob
Which site is it for Peter? Also did you install Vanilla in a separate folder outside your WordPress installation? You should. Also you will need to CHMOD certain files. Here's the installation docs. [url="http://vanillaforums.org/docs/installation"]vanillaforums.org/docs/installation[/url] but make sure you use the same database as your WordPress installation to ensure that we can integrate users and logins.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
pehja
I followed the instructions to the letter. http://pehjaproduktion.se/wp/vanilla. It??s my own site, I thought it would be best to try that first. I created a new database, as instructed in the link you provided. And I also looked at this http://www.pagelines.com/wiki/index.php?title=How_to_Use_Integrations#PageLines_Vanilla. Should i have used another database?? I did something that I am not sure was correct. In the top row when I installed the vanilla forum I put in Localhost..

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
pehja
Should I have put in this instead localhost;unix_socket=/tmp/mysql5.sock

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
Rob
Okay. First, I mentioned earlier to install it to the SAME DATABASE as the WordPress installation, not a new one. I know the instructions say to create a new one but those instructions are not for a WordPress integration. So, go back to the config file and change the database location which is not likely to be localhost. If you're not familiar with these configurations, you may need to call your hosting company.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Simon
What? No... dont use the same database! You will overwrite the wordpress one!!!

Share this post


Link to post
Share on other sites
Simon
That screen at the top there is telling you to create a small file called bootstrap.after.php and put it inside the forum conf folder. The integration script did not have privileges to do it for you.

Share this post


Link to post
Share on other sites
pehja
Ok Simon, I am not so good at this. Create what? and put it where? Is it like I open BBEdit and put the string (in the pic above) and save it as bootstrap.after.php. Then put it in the conf folder in the vanilla folder? Sorry but I need to be absolutely sure

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
pehja
No that was not it... I had major error. Removed the file and now it says "It doesn't look like WordPress and PageLines are integrated correctly. Please integrate WP and activate the PageLines framework." Now I don??t now how to access the vanilla forum at all.

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
Simon
well what was in the file?

Share this post


Link to post
Share on other sites
pehja

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
Simon
'/path/to/wp-load.php' has to be the absolute path on the server to wp-load.php om my server its /home/pross/www/wp-load.php your will be different, if you dont know your path create a file in the wp dir call it info.php and put this in it: [code][/code] Then open it in your browser, the path will be in there somewhere.

Share this post


Link to post
Share on other sites
pehja
I have created the file and put it in the wp dir. But how can I open it in the browser

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
pehja
ok Sorry found It.. Searched for a file "wp-load.php" but could not find it anywhere in the browser.

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
pehja
Could this be right?

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
pehja
all alone again... :-(

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
Simon
if wordpress is in wp folder, then /home/spinneti/public_html/pehjaproduktion.se/wp/wp-load.php

Share this post


Link to post
Share on other sites
pehja
THANKS Simon! :-) Now I am going to learn how this works! Thanks again for all your help!!

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
pehja
Does this thread opens if i post a new coment? Ok lets try! I have changed the original location of my WP installation from http://pehjaproduktion.se/wp to http://pehjaproduktion.se Everything works fine (with a few changes) BUT my vanilla forum that was (and still is) located at http://pehjaproduktion.se/vanilla does not work. I have changed the file bootstrap.after.php and removed "wp" as path. But that did not do the work. When I click on http://pehjaproduktion.se/vanilla I get this "Fatal error: Class 'Gdn' not found in /home/spinneti/public_html/vanilla/bootstrap.php on line 47" I could not find anything strange on that line. I have nothing of importens on the vanilla forum, so it??s no "big deal". But is there a way for me to get this to work or do i (if I can) remove vanilla and install it fresh again? I would appreciate any help I can get on this. @Simon you have helped me before. Maybe you could find it in your heart to do it again :-) Thanks! Peter

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
demeu
I installed on 5th time without any errors. But special page loads more than 25 seconds. Anybody have same problem? Any solution? p.s. only akismet, theme my login, Pagelines Sections, Pagelines Customize plugins activated

Share this post


Link to post
Share on other sites
pehja
I get this when trying to register a new member. Anyone have an idea. I have disabled recaptcha in the settings so it would not interfere. But it seams to do this anyway. Fatal error: Cannot redeclare _recaptcha_qsencode() (previously declared in /home/spinneti/public_html/wp-content/plugins/wp-recaptcha/recaptchalib.php:47) in /home/spinneti/public_html/vanilla/library/vendors/recaptcha/functions.recaptchalib.php on line 55

Professionell musician | Webbdesigner | Apple freak

Pehja Production.png

Share this post


Link to post
Share on other sites
Simon
You have a recapture plugin installed in wordpress as well as vanilla, you cant have both!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×