Jump to content
Sign in to follow this  
martyn

Visual editor not rendering page correctly

Recommended Posts

martyn

Hello My simple 1 row two column html table won't render correctly. When I preview the page in the editor it looks fine. When I publish it, the text data in the second table cell appears underneath the first cell. Here's my code: <table border="0" width="960"> <tbody> <tr valign="top"> <td>box_marketing-11.png</td> <td width="460"> <h2>Social media marketing</h2> We approach social media marketing from two perspectives. One is setting up display advertising on social media platforms, while the other is briefing you and your agencies on the type of content you need to produce for the social media strand of an integrated marketing campaign. Display advertising makes the best of your marketing budgets because it targets customer profile information and user behaviour, allowing you to reach users who have declared an interest in, for example, diabetes, or have searched for a particular word or phrase related to your products. You control the budget by setting daily spending limits and the price you are prepared to pay for each click on your advertisement, and have the confidence that your ads are being seen by people interested in them. We can setup, manage and report on display campaigns for you. Producing the right content for your social media platforms is important because users like to share content. Engaging in a dialogue with users through content becomes a marketing tool that promotes your brand. Users??™ responses to your content are shared with their friends, extending your message and creating word-of-mouth potentially on a global scale ??“ world of mouth. We can advise on the right platform and content to maximise your brand??™s marketing reach.</td> </tr> </tbody> </table> and here's the page: http://www.prosocialgroup.com/?page_id=274 I published the table code elsewhere and it rendered successfully. I get the problem in both Safari and Firefox. I also replaced the text in the second cell with an image and the content did not wrap on to the next line. This only seems to happen with text, whether it is one character or many. M

Share this post


Link to post
Share on other sites
cmunns

Can't you just use the visual editor's image alignment tools to accomplish this e.g. image align-left. Tables are very inconsistent and are quickly becoming extinct in web development . If you don't get enough control using WordPress formatting then I recomment using div's Please let me know if you have any concerns with this.

Share this post


Link to post
Share on other sites
martyn

Thanks Adam. The visual editor alignment eventually did the trick after some experimentation. I promise not to use tables ever again. M

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×