Jump to content
Sign in to follow this  
mbcornett

Box Background Color

Recommended Posts

mbcornett

Hey guys, I've searched the forums over and tried about 25 different ways to give my boxes a background color. Currently I'm using a blue image as my background and don't want a "content color or page color." I simply want the boxes to have a background color (white) with text color (black) so it appears the boxes are "hovering" over my background image. My site has "maintenance mode" active atm, but I will be glad to turn it off upon request if needed. An example of what I'm trying to do: http://blog.morphix.si/

Share this post


Link to post
Share on other sites
James B
Hi, I've looked on that website and I think you'll need to save a white background image as a png with the required transparency. Then upload the image to your media library and use the below code to use that semi transparent white image to tile the background of the box. [code].fbox{ background-image: url(http://your-url.png) } [/code]

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mbcornett
Thanks for the quick response jamieb23 but that did not work. I created a white box (png) via gimp, uploaded it to my media files, and added your code to the custom css box under settings. .fbox{ background-image: url(http://website.com/wp-content/uploads/2012/01/white-box.png) } Please advise.

Share this post


Link to post
Share on other sites
James B
Hi, when I click the link to see the white box file I get a 404 stating the image isn't there. Maybe it didn't copy across?

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mbcornett
that link was correct except for the website.com part. I just used an example since my website has maintenance mode active. Would it not be easier just to add a background color instaed of an image?

Share this post


Link to post
Share on other sites
James B
Yeah you can but it won't have the transparency effect like the website you originally linked. [code].fbox{ background-color: #ffffff; }[/code]

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mbcornett
for whatever reason that still doesn't change it. I'm not sure what I'm doing wrong. I added that code to the settings->custom code, saved options, refreshed page and nothing. Sorry for all this trouble but thank you for trying to help

Share this post


Link to post
Share on other sites
James B
thats so bizarre I've just both on my site and they've worked. Just checking ee are talking "content boxes" aren't we? Not soapboxes or anything else etc. Are you using platform 1 or 2?

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mbcornett
Paglines Framework 2.0.1 and i'm talking about the "boxes." Seen in this image http://bit.ly/wLw8l0 as "Rock The Web "Pagelines Themework" and "Drag&Drop Design"

Share this post


Link to post
Share on other sites
James B
Yup thats exactly the code I'm using for those boxes in the same framework and its working on mine. Try clearing your cache or adding !important; [code].fbox{ background-color: #ffffff !important; }[/code] Sorry I'm out of ideas if that doesn't work. You'll have to reject my answer and wait for a moderator to come along and assist in more depth. If you can put a link up they'll probably go through it in firebug and see what's happening.

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mbcornett
Thanks! That worked. Guess it was just the !important. Now I will continue to try to work on the image for the boxes!

Share this post


Link to post
Share on other sites
James B
Result! So glad it worked out.

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×