Jump to content
Sign in to follow this  
hypman

Is there a way to 'hide' a page for testing purposes?

Recommended Posts

hypman

Hi Im trying to do some a/b testing to see which page my visitors prefer but when i create a 2nd page for test purposes it always shows in the menu, Is there a way to hide this page so my customers dont see 2 similar pages, as i dont think it looks very professional. Thanks

Share this post


Link to post
Share on other sites
revoltoid
you're probably set to automatically add pages to your menu. dashboard/appearance/menus and on the man navigation tab uncheck 'Automatically add new top-level pages' and then create your test page. it won't show up in the menu unless you put it in.

Share this post


Link to post
Share on other sites
hypman
Hi The box is not checked, i added the page and it went on the top menu ? Any ideas?

Share this post


Link to post
Share on other sites
Simon
You have the menus set in auto mode, create a new menu and add your pages manually. Then save it and assign the menu to the main nav in the dropdown topleft of the menu page. Now when you create a new page they will not be auto added as you have a custom menu.

Share this post


Link to post
Share on other sites
hypman
Hi Simon Ive followed what you said and added the new menu, and now the test page doesnt show up but the drop down navigation wont work now even though it is still enabled in the options?

Share this post


Link to post
Share on other sites
Jackey
Did you define any sub-menu's?: [IMG]http://i.imgur.com/va2Cc.png[/IMG]

Share this post


Link to post
Share on other sites
hypman
Hi Jackey I tried that, my screen looks different to yours: mine says 'primary navigation' then below that 'footer navigation' my screen doesnt say simple nav section like yours does. Is this why its not working ?

Share this post


Link to post
Share on other sites
Jackey
No... the order and the names can vary... (my wp is dutch) You should create a menu main, (can be any name you prefer) and select that in the combo box that says "primary navigation". You have to add all the pages to that main menu. (you can organize and add hierarchy to them with drag&drop).

Share this post


Link to post
Share on other sites
hypman
Hi Ive created a main menu, added the pages to it both with and without the drop down pages and it they dont drop down but just sit on the main header

Share this post


Link to post
Share on other sites
Jackey
Can you provide a link?

Share this post


Link to post
Share on other sites
hypman
http://www.hypnosis-to-stop-smoking.co.uk/ the 'contact' page has a contact form page and an address page which are sub pages to it thanks

Share this post


Link to post
Share on other sites
Simon
Can you post a screenshot of your menu page?

Share this post


Link to post
Share on other sites
Jackey
I assume "Contact Form" and "Address" are the submenus of "Contact Us". Please look closely to the menu items in the image I provided. You can see that the menu items are organized and all submenu's are placed underneath and indented to their parent. You can achieve this by dragging&dropping the menu items, and then don't forget to save the menu. Understand that the hierarchy in your page settings do NOT apply anymore.

Share this post


Link to post
Share on other sites
hypman
Ive done it now, thanks. I didnt realise drag n drop was what was wrong!! Many thanks guys : )

Share this post


Link to post
Share on other sites
Jenny
Hi @hypman If you consider this issue resolved, please accept an answer. Thanks!

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×