Jump to content
Sign in to follow this  
ronstahl

Rich Snippets Warnings for SEO

Recommended Posts

ronstahl

I've looked everyplace but can't find an answer as far as my Platform Pro theme so here I am. I'm actually surprised no one else has needed this information but now Google is using way more RICH SNIPPETS for search results and as a result apparently it's affecting page rank for organic search so I need some answers. When I check my pages on Google's new Rich Snippet tool I'm getting 3 warnings that I know can be rectified in the theme but don't know where to do it in mine.The warnings are: Warning: Missing required field "entry-title". Warning: Missing required field "updated". Warning: Missing required hCard "author". Upon searching the world on these errors, below seems to make the most sense and have the easiest fix but I have no idea where to fix it. The article refers to my SinglePost.php, loop.php & Sesrch.php Templates, but every theme is different and I can't find these sections they refer to in mine. I know I should do this is a Platform Base template(s) but their all pretty empty. Can I get a little help as far as where I can place these "hacks"? These errors are caused by the theme itself, which is using the hFeed microformats for the actual page/post content, but without some required data. You can probably very quickly fix this problem by taking the "hfeed" class off of the

.. it doesn't do much with the missing fields. Please Advise???!!!

Share this post


Link to post
Share on other sites
Simon
Rich snippets are not supported in PlatformPro, its built into Framework 2.0 though: http://bit.ly/w5vNF0

Share this post


Link to post
Share on other sites
ronstahl
Well, Thanks for telling me it's built in to Framework 2.0.1 but how exactly does that help me? I need the correct HTML to place it into my Platform Pro, which is the latest version and where exactly to place it. Someone please help?

Share this post


Link to post
Share on other sites
Simon
You cant without editing alot of the core files.

Share this post


Link to post
Share on other sites
ronstahl
Can I use the updated Frameworks templates in Platform?

Share this post


Link to post
Share on other sites
ajstocco
I'm using PageLines Framework 2.1.1, but it does not validate: Warning: Missing required hCard "author" Any idea how to make this work?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×