Jump to content
Sign in to follow this  
couturemotion

Custom CSS Menu but Submenu is off

Recommended Posts

couturemotion

www.couturemotion.com/blog I wanted to move my menu to justify right... it worked nicely. But then I decided I wanted the space between the menu and the search to be less so I added a left:70px to the css. Problem is that the sub-menus didn't move left:70px. I've searched the forums and tried to use firebug to figure out what css I should alter to get the submenus to work properly but I'm have a devil of a time. This is the custom css that I am using on the Menu: ul.sf-menu li {float:right; left:70px} If you go to the site you will see the issue with the dropdown submenu being way too far to the right but the shadow being where it is supposed to be.

Share this post


Link to post
Share on other sites
Rob
Do you have Firebug for Firefox? http://www.getfirebug.com Your code is incorrect. First, it's trying to float right, then, you have it moving left but forgot to add a ; at the end after the 70, I think you need two separate snippets for this but I'm checking. Meanwhile, add the proper end tag and see if that works.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
couturemotion
Added the ; No dice. I got the above float code from reading forums. I do have firebug, but after trying a few elements that I thought might do it, it still didn't work so I thought I'd solicit expert advice.

Share this post


Link to post
Share on other sites
Rob
Okay. Well, I will keep an eye on this and try to get someone on our team with better CSS skills than mine to help.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
kastelic
Hey I keep trying to check your site but it keeps crashing my browser. Have you activated any plugins recently that might do this?

Share this post


Link to post
Share on other sites
couturemotion
I think something is wrong with my server. I contacted the bluehost earlier today and they said they were working on it.

Share this post


Link to post
Share on other sites
Danny
Hi, Try adding this to your custom code: [code]#primary-nav ul.main-nav {width: 810px !important;}[/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×