Jump to content
Sign in to follow this  
seeyou30

Aligning issue. Pagelines 2.

Recommended Posts

seeyou30

Hi!. Im having a problem with alignment of thumbnails. PL 2. Heres a link: hellokitchen .tv First vertical row of the thumbnails grid is the problem. Firebug shows .entry_content *:first-child, .post-excerpt > *:first-child { margin-top: 0; } If I mute margin-top: 0; in Firebug everything is fine. But I cant figure out what to place in Custom CSS tab to get rid of "margin-top: 0". Any help appreciated.

Share this post


Link to post
Share on other sites
Danny
Hi, Add this to PageLines > Settings > Custom Code > CSS Rules: [code]li.fpg-item.fpg-first-col {margin-top: 0.85em !important;}[/code] Refresh your page and see if that works, if it doesnt, then try this instead: [code].home .hentry li {margin: 0 !important;}[/code] This way the code above will only effect your homepage.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
seeyou30
Danny, thank you for your promp answer. However, the suggested solutions didnt resolved my problem. li.fpg-item.fpg-first-col {margin-top: 0.85em !important;} - this code aligns first vertical grid column, but doesnt align left arrow, which is below the thumbnails. And if I scroll the thumbnails with arrows or dots it put the first row down. .home .hentry li {margin: 0 !important;} - this code just messed all thumbnails badly, no good(.

Share this post


Link to post
Share on other sites
kastelic
I noticed a typo in your code, an extra slash at the beginning: [code]/li.fpg-item.fpg-first-col {margin-top: 0.85em !important;}[/code]

Share this post


Link to post
Share on other sites
seeyou30
sorry, i removed this line completely now. anyway this code aligns only thumbnails, not the arrow and if i scroll them, then the first row goes a bit down

Share this post


Link to post
Share on other sites
catrina
This code will align the left arrow with the right arrow: [code]div.fpg-arrow-left {margin-top: 10px;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
seeyou30
still no luck, sorry. it didnt do a thing

Share this post


Link to post
Share on other sites
Danny
OK, please try the following code: [code]li.fpg-item.fpg-first-col {margin-top: 0.85em !important;}[/code] [code].fpg-arrow-left, .fpg-arrow-right {margin-top: 8px !important;}[/code] If this doesn't work, I recommend you contact the plug-in author, as this really isn't a theme/Framework issue.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
seeyou30
Danny, thank you for your help! However, your suggestion has resolved my problem partially. When I implemented your code all thumbnails and arrows align perfectly. But when I scroll the thumbnails I have the same issue with the first column(the arrow stays fine). Keep in mind that the same grid plugin on Pagelines 1.5 works perfectly (here: hellokitchen. ru). So my suggestion is that PL 2 is causing this somehow. As I have said, when I disable margin-top: 0; in Firebug, everything aligns perfectly. What code should I put in Custom CSS for that? [img]http://hellokitchen.tv/wp-content/uploads/2012/01/issue1.png[/img] I have removed your suggested code for now.

Share this post


Link to post
Share on other sites
catrina
Try adding this CSS: [code].entry_content *:first-child, .post-excerpt > *:first child {}[/code] (Hopefully this disables the margin CSS)

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
seeyou30
Catrina, still no luck! It didnt do a thing.

Share this post


Link to post
Share on other sites
Rob
I tested your site and see your problem. I see too that muting the margin-top:0; results in a solution. Crazy as this may seem, have you tried to simply remove that from between the brackets and leave it empty? Since muting it works, obviously the site can tolerate the empty bracket mode. Let me know if this works.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
seeyou30
rangelone, Thank you for you suggestion! It worked like a charm! this was such an easy solution! thanks again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×