Jump to content
Sign in to follow this  
jameschoung

Thumbnail for Single Post Missing

Recommended Posts

jameschoung

My problem: I can't get the featured image to show up as a thumbnail in my single posts. The thumbnails show up fine in other areas, like the main page or the carousel. I do have the box "single post pages" (under "thumbnail post placement") checked, and it doesn't seem to do anything. The other checked boxes do affect their function, so I'm wondering if there is something wrong in the code behind the template. Any suggestions?

Share this post


Link to post
Share on other sites
Rob
May we have a link to your site? Thanks. Also, do you have any plugins (other than ours) activated?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jameschoung
Sure. The link is: www.jameschoung.net And yes, I have other plugins running. They are: Akismet FeedBurner Feedsmith Get Recent Comments Jetpack by Wordpress.com Now Reading Reloaded Post Thumbmail Editor Simple Yearly Archive W3 Total Cache Wordpress Database Backup WP Hide Pages WPtouch Plus two from Pagelines: Customize and Sections.

Share this post


Link to post
Share on other sites
Simon
All i see is the mobile theme, this is probably because the cache plugin is just caching whatever theme the 1st visiter uses then everyone else has to view that cached version.

Share this post


Link to post
Share on other sites
jameschoung
I'll turn off the mobile theme and the cache.

Share this post


Link to post
Share on other sites
jameschoung
Ok -- should be good to check out.

Share this post


Link to post
Share on other sites
Rob
James, I'd suggest turning off all the plugins (just deactivate) and see if the images return. I do not see them in the full post, but do see them in the blog list. Something is blocking them from showing in single post. Deactivate the list of plugins, then, check to see if they show up. I'd also suggest looking in a different browser from the one used to edit the site. Once you determine whether or not they have shown up on single posts, then reactivate each plugin one at a time and see if they vanish. Also, I'd suggest visiting http://www.wordpress.org/extend/plugins and look at each plugin to see if it is compatible with WordPress 3.3.1 or at least 3.2.1. Also, look to see if anyone has reported a similar problem for any of the plugins. If you find something then that plugin needs to be removed and replaced with an alternative. Eventually, as you go through the list of your plugins, you will detect the cause.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jameschoung
I deactivated all of the plugins, and the thumbnail still doesn't show up on the single post. Weird. Is it possible that it's a bug in the framework's code?

Share this post


Link to post
Share on other sites
catrina
I'm not sure whether or not it's a bug. Are you using the latest version of WordPress?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jameschoung
Yes, 3.3.1. It was also doing this on the previous version.

Share this post


Link to post
Share on other sites
jameschoung
It doesn't work in Safari, Chrome or Firefox. I don't have IE installed.

Share this post


Link to post
Share on other sites
Danny
Hi James, This isn't a bug, an error with the Framework or a browser issue. The reason why the feature thumbnails don't display is that you're either using the the thumbnail layout Left, in Excerpt or Right, in Excerpt. Therefore the feature thumbnail image will only display in the excerpt text and not in the full post. This has been noted and is on the trac as a feature enhancement. In the meantime if you would like to have the feature thumbnail visible on both the excerpt text and the full post. I would recommend you use the "Left, Justified" or the "On Top" layout options.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jameschoung
Gotcha. Thanks! Ah, it does say, "in excerpt." :) Sorry about that. Thanks for the help!

Share this post


Link to post
Share on other sites
jameschoung
But yes -- it'll be great to have that for a future feature enhancement.

Share this post


Link to post
Share on other sites
zouleo
I had the same issue. Hoping for an update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×