Jump to content
Sign in to follow this  
nikkikershner

Primary Navigation/Page Attributes

Recommended Posts

nikkikershner

I did another site in the iblog pro template, and in the Platform Pro template I cannot find the Parent Dropdown for the page attributes. The actual Page attributes box does not have the parent dropdown. This is causing the pages created to not show up when I'm trying to set up the navigation. Do I have to publish the pages first? Also, the permalink will not let me take the "/home" off the homepage location. I want it to be the mail url for the permalink. Help!!!! Thank you:)

Share this post


Link to post
Share on other sites
nikkikershner
Navigation and Page Attributes solved (Published Pages). Still need the Permalink solution. THanks!!

Share this post


Link to post
Share on other sites
Rob
Happy New Year! To make sure your static home page is correct lets do just a few things. 1. FTP into your site and CHMOD the .htaccess file to 777. Leave your FTP client open as we'll change it back later. 2. Go to Dashboard > Settings > Permalinks and without changing any of your settings, simply Save. This ensures that the permalink structure you want is written to the .htaccess file. 3. Return to the .htaccess and CHMOD to 644 for security reasons. 4. Go to Dashboard > Settings > Reading and make sure you've selected "A static page (select below)" and that the home page you've created is selected as the first drop down selection. If you have a blog page, that should be selected in the second drop down list. Save your settings. 5. Test the site. Go to the site in a different browser and click the Home page link on your menu or your branding logo. If it still says "home" at the end of the URL go to step 6. 6. Go to Dashboard > Appearance > Menus and check the menu item for the homepage. Click it in the menu list. It will open. Make sure the URL does not have /home at the end. If it does, then edit that out. Save the menu.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nikkikershner
Um, You might have to slow down for me a sec, I'm stuck at #1. lol I understand the rest but when it comes to editing code files I'm pretty much illiterate. Can you tell me how to do step one for dummies?

Share this post


Link to post
Share on other sites
Rob
Sorry, my fault. FTP can be done with an FTP (File Transfer Protocol) client or, through a file management tool provided via your hosting company. If you have an FTP client, you need to log into your site, then, find the .htaccess file. It's possible you don't have one. Can you let me know if you have an FTP client or if you use a tool such as cPanel or Plesk file manager? I'll take this step by step with you, happily.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nikkikershner
I'm just using the Bluehost FTP manager.

Share this post


Link to post
Share on other sites
Rob
Okay. When you log in, do you see the file's permissions or a numeric or alpha value under a heading for "Permissions"? Do you see a .htaccess file in your site? BTW, I'm not going to leave you in the middle of this so don't worry. Even if we have to pop a cork tonight, I'll be here.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nikkikershner
don't see one. it would be in the main root folder correct and not in the wp-content folder? Don't see one.

Share this post


Link to post
Share on other sites
Rob
Yes and no problem. Open a text editor. Save the file as htaccess.txt. Upload the file to the root where Wordpress is installed. You should see the wp-admin, wp-content and wp-includes folders. Once the file is uploaded, rename the file to .htaccess and remove the .txt. Let me know when you get that far.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nikkikershner
so in the text edit file type "CHMOD777" and then save as htaccess.txt? Then proceed through the rest of the steps.

Share this post


Link to post
Share on other sites
Rob
No. Save as DOT HTACCESS ( .htaccess) as if the htaccess replaces the .txt with nothing in front of the period. Then, you should have a column in your file manager for file permissions there, someplace. You may need some help from your hosting company for this. But if you tell them you need that file CHMOD to 777 they'll understand. Tell them it's temporary (which it is). You may need to call them for this help.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nikkikershner
I KNEW THIS WAS SOMETHING STUPID EASY!!!! Settings > Reading > Front page displays (choose) A Static Page (Home). The Wordpress default is your latest post, so you have to manually change it. Dang it!

Share this post


Link to post
Share on other sites
Rob
Bingo! Item 4 on my list! Now you can have a Happy New Year!

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nikkikershner
If only I read to item 4 sooner! hahahaha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×