Jump to content
Sign in to follow this  
pernillaoberg

PageLine Framework 2.0.1 update?

Recommended Posts

pernillaoberg

When I try to update by following the update-link in my dashboard I get the message "forbidden"? http://www.akersjon.com Best regards Pernilla

Share this post


Link to post
Share on other sites
Danny
Hi Pernilla, This has been reported a few times, there may be an issue with the update. To resolve this, login to your PageLines Launchpad, download PageLines Framework 2.0 and manually update the Framework.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
pernillaoberg
Thanks for your fast reply! You mean I should reinstall 2.0 and then update 2.0.1? Maybe that will do it also for the "store" because it doesn't work properly, when I try to install something it says "Installing" and then "-1", so I manually installed all the sections from http://api.pagelines.com/store_free/ but I can't install soapbox-sections.

Share this post


Link to post
Share on other sites
Danny
Hmmm... now that sounds like it could be something else. I would recommend holding updating until one of developers can answer this issue. I have flagged it for developer attention.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
pernillaoberg
Hello again Danny! I know you flagged my question but do you know when someone please can take a look at it? I'm a bit stuck, need to finish the site and would like upgrade and also be able to use the soapboxes... Best regards. Pernilla

Share this post


Link to post
Share on other sites
Simon
Can you show me a screenshot of the forbidden error?

Share this post


Link to post
Share on other sites
pernillaoberg
Hi pross! Screenshot from when I try to upgrade by following the link in the dashboard: [img]http://akersjon.com/wp-content/uploads/2012/01/error2.jpg[/img] If you don't know the global language swedish it basically says that a problem occurred and the upgrade failed = Forbidden! Also I still have problems with the store and here's a screenshot from when I try to install the soapbox sections: [img]http://akersjon.com/wp-content/uploads/2012/01/error3.jpg[/img] First there is the same grey box saying "Installing" and then it freezes at the message "-1". I've tried installing with all plugins and widgets inactive, but no change. Today there is an update to Wordpress but I haven't tried, I'll just wait for some advise about what I made wrong here. /Pernilla

Share this post


Link to post
Share on other sites
Simon
Looks like your server is unable to communicate with our server to get the files. Do normal wordpress updates work? Can you install an update or a plugin through the wordpress interface?

Share this post


Link to post
Share on other sites
pernillaoberg
Haven't dared to do the Wordpress 3.3.1 update yet, wanted to check with you first about the other issues, but I grabbed some plugin just now to test to answer your question - no problems: [img]http://akersjon.com/wp-content/uploads/2012/01/pageline-support-1.jpg[/img] I haven't been able to use the store, I've made all installations manually in WP by downloading the files from http://api.pagelines.com/store_free/ I got them in place except for the soapbox-sections http://api.pagelines.com/store_free/section-pagelines-soapbox.zip it won't work and I get a message that says something like the file is not "valid", if I translate it correct. /Pernilla

Share this post


Link to post
Share on other sites
Simon
Thats because it is a sections not a plugin. It has to be either unzipped and uploaded to wp-content/plugins/pagelines-sections/ or there is an uploader function in the store under sections.

Share this post


Link to post
Share on other sites
pernillaoberg
Sorry! It's really embarrassing being such no-brainer but I have to try to swallow my pride because PageLine is so much fun, it gives endless opportunities for me in the company I work in and I don't want to give up just yet. Or am I in over my head, maybe it's foolish to even try understanding without any coding experience? I've asked this question before: http://www.pagelines.com/forum/discussion/comment/84807#Comment_84807 After your advise @pross I deleted a plugin and the layout of PageLine's dashboard went back to normal. But I still get the same message when trying to upload in the store, maybe the plugin caused a fatal error during my upgrade to PageLine Framework 2.0? I was so eager when the release of 2.0 came and didn't do the homework before hitting the button - I didn't deactivate plugin's/widgets and I caused the site to turn totally blank when upgrading. The host ran a backup for me and another time they increased some kind of memory, they said the problem might have been due to a script in one of my widgets. I'd really like to use the soapboxes and also try to understand the conflicts that need to be solved. As I showed before this is what happens when I try to install soapboxes in the store: [img]http://akersjon.com/wp-content/uploads/2012/01/error3.jpg[/img] I found the free zip-files in another thread here in the forum and downloaded them to my computer: [img]http://akersjon.com/wp-content/uploads/2012/01/pageline-support-2.jpg[/img] But they all ended up as folders, not zip-files: [img]http://akersjon.com/wp-content/uploads/2012/01/pageline-support-3.jpg[/img] I therefore converted them to zip-files and installed them through WP, a least I thought I did, and the only thing that I know I'm missing are the soapboxes: [img]http://akersjon.com/wp-content/uploads/2012/01/pageline-support-4.jpg[/img] When I try to upload my soapbox-zipfile in the store/sections: [img]http://akersjon.com/wp-content/uploads/2012/01/pageline-support-5.jpg[/img] ...I get this message that the file isn't a PageLine section: [img]http://akersjon.com/wp-content/uploads/2012/01/pageline-support-6.jpg[/img] And as I said I'm not able to upgrade to 2.0.1: [img]http://akersjon.com/wp-content/uploads/2012/01/error2.jpg[/img] /Pernilla

Share this post


Link to post
Share on other sites
Simon
when you download soapbox from the free folder it is section-pagelines-soapbox.zip right? Upload it like this in the store uploader. Do not rename it.

Share this post


Link to post
Share on other sites
pernillaoberg
Yes, it was that file... I gave it a try again, but this time I right-clicked the link in the "store_free" and suddenly saw the option "get linked file as" - earlier I just clicked the link to start the download and then ended up with just a folder, no zip. No wonder it didn't work... Now the file is neatly installed through the store uploader but why do I need to upload them manually, why don't the uploader work when I hit "install" in the store? I just tried to install the ContentBox in store->sections again but got the "-1"-message, same as before so I right-clicked it in http://api.pagelines.com/store_free/ and now I have that to, great! Nothing's more joyful than finding solutions! :-) Is there a similar way to get the 2.0.1 upgrade or is there something seriously wrong with my (me?) 2.0 installation?

Share this post


Link to post
Share on other sites
Simon
Your server is blocking connection to ours to get the files: [code]root@socrates [~]# ping akersjon.com PING akersjon.com (195.43.151.103) 56(84) bytes of data. --- akersjon.com ping statistics --- 11 packets transmitted, 0 received, 100% packet loss, time 10003ms[/code]

Share this post


Link to post
Share on other sites
pernillaoberg
Can I ask you why? Is that because of the host's server security settings or what? Do I adress them or is it something I should be able to solve by my self in the ftp or elsewhere?

Share this post


Link to post
Share on other sites
Simon
No you need to ask them why your theme cant download files remotely from our server. Our IP is 68.233.248.54

Share this post


Link to post
Share on other sites
ntsmedia
Hi ... I was asked to add my problem in here as it may be similar. I am having a problem getting the Sections Plugin to install from within the WP/Pagelines admin. It shows a grey overlay and says it's installing and then pops a layer asking for FTP connection info. Giving that info and clicking submit (or whatever the wording may be) freezes the site. Not sure what it really does or why but I typically need to reboot the server to get the WP site and admin back. I do have a firewall limiting FTP on port 21 to specific IPs but I tried opening FTP completely and even turned off the firewall without success. I am going to try opening FTP to the Pagelines IP but I use non-passive connections. Should opening only port 21 for that IP work? I do not use WP installing and prefer to load all files (plugins etc.) manually. But I did try getting a simple plugin (Wordpress Importer) to update "automatically" and it spun on the page for a long time even with the firewall off too though it didn't freeze the system. Perhaps the uploading is not a Pagelines issue but can I install needed 2.0 items manually? This server is running PHP 5.2.2 so until I can upgrade that, I cannot use any greater than WP 3.14 which is what I am testing the Pagelines 2.0 out on. Might this be a possible source of the problem? Regards, John

Share this post


Link to post
Share on other sites
Simon
John, it could well be a problem. Why do you run an old insecure version of php? Is this your server or are you limited by your host? Running an insecure version of wordpress because of your hosts inabilities to upgrade is a bad situation to be in. Anyways, port 21 does not have to be open to the internet anyway, this is how it works: You click install in the store... wordpress remote fetches the file using SSL if it can or falling back to standard HTTP if it fails, once the file is fetched it extracts it and connects to your local filesystem using PHP's FTP class, so really you only need localhost whitelisted. It uses the local FTP to put the files i the right place with the right ownership. Of course if the server was running suPHP or fastCGI or mod_fcgid or even mod_itk all thsi wouldnt matter as the web process would be using your username anyway and wordpress would use the filesystem directly.

Share this post


Link to post
Share on other sites
Jackey
Ever since I started working with Wordpress and Pagelines products I had problems with permissions on my installation. I changed ISP's at no avail. Thus managed by manually installing themes and plugins. With the release of Pagelines Framework that has its own Store, permission problems where popping up all over the store, preventing me to install extensions the way they where presented. (automatically) Frustrated and eager to get to the bottom of this I started investigating and found that the ISP runs the site as a different user than me (the username I was assigned by the ISP). This seems to be very common. I requested my ISP to install suPHP, which he was willing to do. (it seems this is not a PnP thing). This mod makes sure that the site runs with the rights of the owner. For me, this solved all my permission problems. Wordpress theme and plugin updates execute lighting fast ever since. I also never had to resort to give folders 777 permissions, to make things work. [b]So I think Simons advice:[/b] [quote]Of course if the server was running suPHP or fastCGI or mod_fcgid or even mod_itk all thsi wouldnt matter as the web process would be using your username anyway and wordpress would use the filesystem directly.[/quote] [b]Is gold![/b]

Share this post


Link to post
Share on other sites
ntsmedia
Thanks to all for the insight. I do plan to upgrade PHP and thus have the option to run more recent WP versions on the server in question soon but I doubt that's the problem preventing the auto-updating. I will look into suPHP in the meantime and see what else might be preventing my system from handling this based upon the description of the process Simon provided. I take it that the new Platform relies upon the auto-install process and that manual downloads and installations are not possible? As a side note ... I see that the next to most recent WP version had to be quickly updated due to security issues so I'm not always willing to assume the latest is always the greatest. Many Thanks, John

Share this post


Link to post
Share on other sites
Simon
Trust me John, The latest is always the most secure, the fixes are added to the latest version of wordpress, they do not run a legacy branch and backport the fixes. You are introducing your own security risks by not upgrading, and those are the type of sites the script kiddies look for.

Share this post


Link to post
Share on other sites
pernillaoberg
Just want to say THANKS to you Simon for your help! I asked our host and they opened the security settings for PageLine and then the update went great, no problem with the store now. I could have spent years searching for the problem without ever finding it so I really appreciate your help! Didn't realize PageLine came with all this support, it's amazing to be able to ask professionals for advise when your'e stuck and can't find the answer. Great! /Pernilla

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×