Jump to content
Sign in to follow this  
barbosa

Change color of the menu

Recommended Posts

barbosa

Hello, How change the color white to another color? Or keep the same color. 2naptdx.jpg Pagelines 2.0 (localhost) My custom css:

.main-nav ul a{ color: #4c4c4c !important; }
	.main-nav ul a:hover{ color: #717171 !important; }
	.current-menu-item a {background-color: #e8e8e8 !important;}
	.current-menu-item a:hover { background-color: #f7f7f5 !important; color: #565656 !important;}
	.main-nav li a{ color: #fffbf1; border: 1px solid transparent; }

Thanks!

Share this post


Link to post
Share on other sites
catrina
You should be able to change this line: [code].main-nav li a{ color: #fffbf1; border: 1px solid transparent; }[/code] to this... [code].main-nav li a{ color: #fffff; border: 1px solid transparent; }[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
barbosa
Hi catrina, [img]http://i43.tinypic.com/10pwqyg.jpg[/img] It worked in parts, but I would keep the white color to the rest of the menu. As the image below: [img]http://i41.tinypic.com/2zq50rc.jpg[/img] Thanks :D

Share this post


Link to post
Share on other sites
Danny
Hi Barbosa, Try this please: [code].sfHover a {color:#fffbf1 !important;}[/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
barbosa
Hi Danny, doesn't work. Look what happens: .sfHover a{color:#fffbf1 !important;} [img]http://i41.tinypic.com/dwvog.jpg[/img] i try .sfHover ul {color:#fffbf1 !important;} (doesn't work), .sfHover li {color:#fffbf1 !important;}(doesn't work) and .sfHover li {color:#fffbf1 !important;} (has same effect as the code catrina) Yesterday I was several hours using firebug and could not find a solution. Thanks

Share this post


Link to post
Share on other sites
catrina
It would be super helpful if there was a live link available. In Firebug, what is the entire code for generating the parent link that is hovered over and the parent link that isn't hovered over?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
indakno
So there is a way to change the color and font of my navigation menu? If so, how please. http://indakno.com/atl/

Share this post


Link to post
Share on other sites
indakno
Where does it go? In the CSS editor section?

Share this post


Link to post
Share on other sites
indakno
will this enable be to change the background of the navi also? I want the whole navi row even to the search bar to be black. The text to be white,and the ability to change the font type. Is that possible without having to get a plugin?

Share this post


Link to post
Share on other sites
catrina
Different CSS will be needed. Try this: [code]section#nav {background-color: #000; font-family: FONTNAME;} You'll need to change FONTNAME to the font you want.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
indakno
The first code worked fine, just needed to change the color. This code doesnt seem to work. No colors chnaged. No fonts changed.

Share this post


Link to post
Share on other sites
indakno
Also, I need to be able to control the size also. I need smaller menu font. If I can get this part, I will be 75% done with the site. The other issue is the feature issue which I was told will be fixed in another update.

Share this post


Link to post
Share on other sites
barbosa
Unfortunately, I have a link for you to check. Your last code in the menu left white, but returned to the first case :(. [img]http://i42.tinypic.com/2naptdx.jpg[/img] any suggestions for ".sf-with-ul"? I tried: [code].sf-with-ul li a{color: #4c4c4c !important;} .sf-with-ul a{color: #4c4c4c !important;}[/code] But nothing works. Any other ideas? Image of firebug with the classes: http://i40.tinypic.com/v30qcz.jpg

Share this post


Link to post
Share on other sites
kastelic
Is there any way you can copy the site to a live server so that we can inspect it?

Share this post


Link to post
Share on other sites
barbosa
Hello catrina, Danny and kastelic. I just sent a message to you with the information necessary to access the URL of my site. Unfortunately, I could not import the settings made and had to make the settings manually. I disabled child theme and using the plugin customization. Thanks

Share this post


Link to post
Share on other sites
kastelic
Try these two rules: [code] .sub-menu a { color: blue !important; } .sf-with-ul { color: red !important; } [/code]

Share this post


Link to post
Share on other sites
barbosa
Hi kastelic, Works ok for these colors. I used your code and changed my colors with the following code: [code].sub-menu a { color: #4c4c4c !important; } .sf-with-ul { color: #f7f7f5 !important; }[/code] The end result is as shown above: [img]http://i42.tinypic.com/2naptdx.jpg[/img] Thanks

Share this post


Link to post
Share on other sites
barbosa
Sorry if I expressed myself badly, but still need support... The code doesn't work on my theme. I still have the problem of the link when the mouse is not over as I showed in the previous image. [img]http://i42.tinypic.com/2naptdx.jpg[/img]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×