Jump to content
Sign in to follow this  
leografie

Pagelines Customise Plugin not functioning after 2.0.1 update in Multisite?

Recommended Posts

leografie

I recently manually updated 2.0.0 to 2.0.1 and all customizations in the functions.php and style.css files are no longer being applied to the site(s). I rolled back to 2.0.0 without making any changes and the customizations were applied again. I created a fresh wordpress install with the default (sample) wp content and 2.0.0 theme with the plugin and was able to replicate the issue through both manual and automatic updates. I have both left 2.0.0 active and deactivated (using Twenty Eleven) when updating to 2.0.1. Could there be an activation issue between the Pagelines Store/Local Site "Activate" and the Multisite Network Admin "Network Activate"? If I Network Activate the plugin in Network Admin the plugin of course does not show in the site plugin list (normal WordPress behavior). It does however show that it is deactivated in the Pagelines Store. If I "Network Deactivate" in Network Admin, the plugin is still activated in the site(s) if I activated it there previously. The same applies to to the Pagelines Sections Plugin. After trying several setting changes, I tried to roll back to 2.0.0 by deactivating 2.0.1 and replacing the pagelines theme folder with 2.0.0 and the problem now persists in 2.0.0. Any suggestions?

Share this post


Link to post
Share on other sites
Rob
Our developers are currently away for the holidays and will not be available until later in this week. Please be patient. I have flagged this to them for their attention.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
leografie
Thanks rangelone for answering over this time of year. I will wait, however I would consider it a show-stopper for those with deadlines, particularly if they lost the 2.0.0 files. Another reason to keep backups before upgrading. I've also tried a new WP installation with 2.0.1 and saw that the functions.php and style.css customisations function in a single site setup prior to enabling a multisite environment.

Share this post


Link to post
Share on other sites
leografie
I figured this out after some clues here in the forum. When you install the Pagelines Customise Plugin, you need to locate that folder (wp-content/plugins/pagelines-customize) and add a folder "blogs". Into that folder you create a new folder based on the ID of your site. The initial site's id is "1", the second site "2" and so on. To find the ID, if you have a multisite, login to your admin area, navigate to Network Admin -> Sites -> All Sites and edit the site you want to find the id of. You'll see the ID in the url of the page (see below) http://yoursitename/wp-admin/network/site-info.php?id=1 Your initial site will have the folder: wp-content/plugins/pagelines-customize/blogs/1, your second site will have the folder: wp-content/plugins/pagelines-customize/blogs/2 and so on. You can copy the functions.php and style.css files into each folder, thereby enabling separate customisations for each site (ID). Would be nice to see this in the documentation.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×