Jump to content
Sign in to follow this  
bokeh

cannot login and site down after functions.php change

Recommended Posts

bokeh

Hi, I hope somebody can help. I wanted to add a telephone number above my social icons. So I went to the customise widget, found the functions.php and added this code. add_action('pagelines_before_branding_icons', 'custom_contact_info'); function custom_contact_info() { ?> <div id="contact-info"><p>info@businessfootprint.net</br> T:07808071089 / 0208 2495366</p></div> <?php } After that my site went down and I cannot login to my wordpress admin area. I do have a backup on my desktop, I just don;t know what to do with it. Please help.

Share this post


Link to post
Share on other sites
bokeh
I've logged into my website host directory, and on their instructions have been able to get into the customize plugin functions.php, and have deleted the code I i have previously put in, as above. I still cannot log into my admin and my site is still down. Is there a bug in the customize plug in? Any ideas of what to do now?

Share this post


Link to post
Share on other sites
Simon
No there is not a bug, whatever code you put in that functions.php gets included by wordpress. If you still have errors in that file it will still crash. Check your error logs. Usually PHP will make a file called error_log somewhere on the FTP, it depends on your host though.

Share this post


Link to post
Share on other sites
bokeh
The customize plugin, functions.php file now contains: array( 'name' => 'Ubuntu', 'family' => '"Ubuntu", arial, serif', 'web_safe' => true, 'google' => true, 'monospace' => false ) ); return array_merge( $thefoundry, $myfont ); } /* // ==================================================== // = YOUR FUNCTIONS - Where you should add your code = // ==================================================== which is exactly what it was before. Can you see something here that would cause my whole site, including admin login to crash?

Share this post


Link to post
Share on other sites
Simon
try deleting all of it, just leave

Share this post


Link to post
Share on other sites
bokeh
well, I ended up rewriting my whole Dir files via the backup I did yesterday before installing WP3.3. I then had to redo all my file permissions, coz the back-up didn't do that properly, and move across my old access file, as the back-up didn;t do that either. All is now as it was yesterday, and my website is, at least up and running and I have admin access. Is Framework fully WP3.3 tested?

Share this post


Link to post
Share on other sites
Simon
Of course! It was developed with 3.3 ever since it was beta.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×