Jump to content
Sign in to follow this  
laka74

Problem with posts

Recommended Posts

laka74

Dear support, First - my website is not a blog-site, it is much more static like a "normal" website. But I do have some posts located at the page called "Lige nu" (that's danish) there should be three posts at the moment. The problem is when you click on one of them, then you get redirected to some other page, which I don't understand. I also have a widget on the front/home page near the buttom, which is supposed to direct you to the posts when clicked on, but I can't get that to work either. It's probably easy - like most of the other issues I've had (love Pagelines) and the support. Best regards Lasse

Share this post


Link to post
Share on other sites
Simon
Are you sure the permalinks are set correctly under wordpress/setting/permalinks.

Share this post


Link to post
Share on other sites
laka74
My permalinks are set to "Standard"....I didn't change anything.

Share this post


Link to post
Share on other sites
Danny
Hi Laka, Can you post a link to your site please ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
laka74
Sorry - forgot. www.der3raum.com

Share this post


Link to post
Share on other sites
Danny
Not sure what's happening there, it's pretty strange. As a test, can you go to Wordpress > Settings > Permalinks and in the custom structure add this /%postname%/ And then save, make you to click on the radio button on custom structure.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
laka74
Thanks Danny - but no change ?!?

Share this post


Link to post
Share on other sites
Danny
Hi Laka, I asked you to do this not to fix the issue but to see URL of the posts. How did you create the "Lige Nu" page? I'm asking this, because when I click one of your posts the URL is this: http://der3raum.com/archives/223 Normally, when you use the /%postname%/ it will display like this: http://der3raum.com/Form So how have you created the "Lige Nu" page and displaying your posts on that page ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
laka74
I have just created a "New page" and under the WP Settings made that page "Lige nu" the post-page. There is an option where to choose a "Home" page and a "Blog/post" page. The home page is "Forside" and the blog page is set to "Lige nu".

Share this post


Link to post
Share on other sites
laka74
And BTW - you are right....when using the /%postname%/ in the wp settings, my url looks as you describe. But I'm still looking for a fix because it's not working. Try clicking on "Status p?? sitet" and you will get a blank page ? Best Lasse

Share this post


Link to post
Share on other sites
Kate
Hey Lasse, Try assigning your Permalinks to "Default", and then choose "Save". Then re-assign them to the Permalink setting you had to begin with (eg: "Day and Name", "Month and Name", etc.). Then choose "Save". Might just need to "reset" the permalinks. But, I have a feeling that's not the issue. On a related note: WP actually says: "Starting Permalinks with %postname% is strongly not recommended for performance reasons.." Have you considered a different structure? http://codex.wordpress.org/Using_Permalinks

Share this post


Link to post
Share on other sites
laka74
Hi Kate, Thanks for responding. I don't think that permalinks is where the problem is - now I've tried all settings under permalinks....with no difference. When clicking on for instance the post called "Velkommen" you will get a blank page with this url: http://der3raum.com/?p=60 Could it be under PlatformPro settings "Blog and Posts" ? When clicking on a post - even if you can see all text content - I would expect to be directet to a new page containing that same post.....right ?

Share this post


Link to post
Share on other sites
Rob
Lasse, Before changing permalinks, it's important to change the permissions (CHMOD) of .htaccess to 777 so that WordPress can write the new rules there. Without the .htaccess being writable, the Permalinks page will give you code to add to the .htaccess file that most people don't see or do. When the permissions are 777, WordPress makes the changes automatically, so you do much less work. I'd like you to also do a test - add a new post, complete with a feature image and see if it appears normally. If it does, please go to the two posts where nothing shows up correctly and make sure that you do not have "Hide Content" checked anywhere. Let me know if this works.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
laka74
Hi rangelone, Of course - it was my Main Content and Content Area on the specific post I needed to change. You are great, always spot on. Best Lasse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×