Jump to content
Sign in to follow this  
christycollins

HOST KEEPS SHUTTING DOWN SITE! H-E-L-P

Recommended Posts

christycollins

Dear Christy, As mentioned in earlier email the specified 'wp_comments' table within the database 'wordpress_1_cci' contains spam/ porn contents which is violating our TOS as well as server performance to degrade. You need to clear all the unwanted rows from the mentioned table to avoid the suspension of Website and also do a maintainence on this application in-order to avoid spammers/ hackers targeting your application for their means of populating spam contents. If the comments/ posts are unused then you can directly empty the database table or else you need to go through all the comments and must delete the spam/ unwanted entries. For example in the table 'wp_comments' comment_ID 1665 contents 'http://www.1pornoizle.tk', 2487 contents 'http://www.sikisporno.com' and 1400 contents 'viagra'. Please delete such entries from your database table. You can make use of the "Search" Tab to the remove the spamming contents. This is one of the finest procedure to filter out the unwanted entries found in the database. 1. Firstly, log into the phpMyAdmin section and click on the database in the left pane which directs to the detailed information of the tables at the right pane of the interface. 2. Click on the "Search" Tab at the top of the right pane which will precede you to search option. 3. Going forward you need to insert certain keyword (say porn/ sex/ viagra/ penis) that are found in the table contents and click on the "Go" button. 4.Automatically it will list out the contents constituting the spam records across each tables. Finally, you need click on "Browse" and perform the action to make the database spam free. Please note that we've already given you more time to act on this issue and we've not seeing any significant changes on your database and it still hogging the server resources as its being a victim of spammers and your account will stay on un-suspended status for next 24 hrs and if there is no significant changes then we are forced to suspend your website services again. Please take immediate action on the specified database and get back to us with the details of work done. So, that we can get back to you with updated status. If you have any questions, please do not hesitate to contact us: http://www.ipower.com/support/contact.bml Sincerely, The IPOWER Team

Share this post


Link to post
Share on other sites
christycollins
Rangelone Can you please be specific what I need to do here. Ipower has now shut down the site again. I went into the folder on the host site and deleted the comments.php.

Share this post


Link to post
Share on other sites
christycollins
Is there a way stop all comments at this point?

Share this post


Link to post
Share on other sites
mrcbrown
Sure - within Wordpress itself you can disable Comments - goto: /wp-admin/options-discussion.php Off your domain, this will take you to options for allowing comments, shut em down and I'd highly suggest Akismet or or other free Anti-Spam solutions. Once Akismet plugin is installed it does have a Check Spam option in the comments (/wp-admin/edit-comments.php) section, it will help you disable bogus comments from bots. I know this isn't super specific to your particular install, but it's a bummer that your host is pulling the plug, but you must be getting hit pretty hard - if they'll re-enable you, disable comments, enable Akismet Plugin, and do a check for spam and the road to clean-up will begin. -CB

Chuck Brown

Share this post


Link to post
Share on other sites
christycollins
I am having trouble finding this...Is it inside my wordpress administration panel? /wp-admin/options-discussion.php Also, I did have Akismet active. I appreciate all your help.

Share this post


Link to post
Share on other sites
christycollins
Ok I found it... http://www.christycollins.com/wp-admin/options-discussion.php But, I did have both of these checked...what else can I do? X Comment author must fill out name and e-mail X Users must be registered and logged in to comment

Share this post


Link to post
Share on other sites
mrcbrown
[img]https://img.skitch.com/20111213-e19w73j8wi6miscgmbb1tshau2.jpg[/img] Check those for now, but I am willing to bet the big thing after that is going to be cleaning out all of the spam comments - I speak from experience as I am the owner of a hosting company, and have helped customers thru similar situations. Head to the comments area after you've checked those and if Akismet Plugin is configured & active, then give the "Check Spam": [img]https://img.skitch.com/20111213-faqdjiqgnn7b2qr8u2pkk1qtq6.jpg[/img] This will go thru your comments that have been made and help to eliminate them and send them to the trash, with comments requiring approval & re-checking for spam, this should help appease your host but you may want to consider long-term if you do want comments to try a system like Intense Debate (http://wordpress.org/extend/plugins/intensedebate/) or Facebook Social Plugin (http://wordpress.org/extend/plugins/facebook-comments-for-wordpress/) - both should take some load off your hosting company and help calm some sys-admin nerves! Hope it helps! -CB

Chuck Brown

Share this post


Link to post
Share on other sites
christycollins
You are great! Thanks Ill keep trying. If I or wordpress marks a comment as spam, do I then need to permanently delete it somehow? Also is there a way to mark "all" unapproved comments as spam without having to go through each page. I have 1100.

Share this post


Link to post
Share on other sites
christycollins
Also I threw away the comments.php in the folder on my host file manager. Was this the wrong thing to do? So far I have not seen any problems from deleting that file. I did it in a panic.

Share this post


Link to post
Share on other sites
mrcbrown
Removing the comments.php will simply break the ability to create the form that collects comments, so probably a good idea for now should help fend off bots from directly posting to that file so safe, later you can re-add it if you need comments. As for mark all? Once you have marked them as spam, or Akismet has noted them, you'll be able to hit "Empty Spam" and it'll clear out all spam marked comments and cleared out for ya. Glad to help, hope this helps get you squared away and the crew @ iPower will see your making an effort and work with you a bit more, good crew over there! -CB

Chuck Brown

Share this post


Link to post
Share on other sites
Rob
Christy, CB has given you outstanding suggestions and support. As good, if not better than I would. He's correct about Akismet. It's a critical component to all of your sites. I'd also suggest that if you don't need comments, that you simply remove the form from the templates to ensure no one can post anything. If you want legitimate comments, use a plugin like Disqus. You will still, unfortunately stand the risk of being spammed, but you'll at least be able to catch them before they go public and violate your TOS.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
christycollins
They shut me down again. They are telling me that I have to delete the comments in the database in my IPOWER login, but they can't tell me how to do it, they say that wordpress can only answer this. The last thing I did on the IPOWER site page is to DELETE the comments.php in that database that they are talking about, but I can't get any specific "porn" comments to come up to specifically delete. They simply can't walk me through where they are. Since the last shut down, I updated my Pagelines site and double checked to make sure that all of the spam comments were deleted. So at this point I have all comments shut down. One comment made by IPOWER was that there is a script somewhere that is allowing these porn sites to attack me. Any further advice? I don't know what else to do. I have saved all of your recommendations for the future in case I want to reinstate "comments"

Share this post


Link to post
Share on other sites
catrina
You need to make sure your Akismet settings are correct. Also, try deactivating all plugins and check to see if there were any complaints about those plugins.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Rob
Christy, I'm glad we resolved that matter and I'm confident you will not have any additional commenting problems. I should have mentioned that it would be a good idea to go to http://www.wordpress.org/extend/plugins and look up each of your plugins to make sure each is up to date; that there are no complaints by other users and that the plugins are compatible with at least WP 3.2.1.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×