Jump to content
Sign in to follow this  
ah2evoxy82raqhs

Blog Page Sidebars

Recommended Posts

ah2evoxy82raqhs

I have Widgets set up for Primary, Secondary and Tertiary Sidebars. I have two widgets in the Primary Side Bar, a custom menu widget in the Secondary sidebar and a text widget in the Tertiary sidebar. The problem is that on the Blog Page the content of ALL of the sidebars show up. I only want the Primary Sidebar to appear on that page. How do I exclude the Secondry and Tertiary Sidebar content from displaying on the Blog page. Thanks, John

Share this post


Link to post
Share on other sites
Rob
John, go into Dashboard > Pages and find the blog page. Edit it. Scroll down to PageLines Meta Settings. If you don't see that, go to the top of your screen, to the right you'll see "Screen Options". Check PageLines Meta Settings and then click "Screen Options" again to close the option panel. Now you can scroll down and you'll see the Meta Settings. The first panel should have little boxes with a checkbox in each to hide various elements of the page. Check the boxes for the sidebars you do not want and save the Meta Settings and then update your page. View the page. (If you have a cache plugin, you may need to clear the cache). Only the sidebar(s) you want should appear.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ah2evoxy82raqhs
Thanks, but it appears that the "blog" page is a "special" page. The Meta Settings were checked in "Screen Options" but there is this little message that appears on that page where the Pageline Section Controls should be: "Note: Individual page settings do not work on the blog page (use the settings panel)." And yes, I tried going to the settings panel, but couldn't seem to find the controls I needed there either for the "blog" page. :( Any other ideas?

Share this post


Link to post
Share on other sites
catrina
You can exclude those sidebars on the blog page using CSS (in Template settings for Blog, the sidebars can't be hidden).

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ah2evoxy82raqhs
Thanks Catrina. Could you please be a bit more specific? i.e. step by step instructions including sample of CSS.

Share this post


Link to post
Share on other sites
Jenny
I believe you can use Widget Logic to help you change which sidebars appear on which pages. I haven't used it myself but several people have and seem to love it.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
suecrawfordesign
Oh, I am having the same issue! All of the sidebars are showing up on my blog page, and I can't find a way to control it. Would love to find a fix for this! Thanks, Sue

Share this post


Link to post
Share on other sites
catrina
You can try what Jenny suggested: [url="http://wordpress.org/extend/plugins/widget-logic/"]Widget Logic[/url], a plugin that gives you better control over your widgets

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
suecrawfordesign
Thanks, but I tried the Widget Logic plugin and it didn't give me the options I needed.

Share this post


Link to post
Share on other sites
catrina
The only other option I can think of is to use CSS to hide certain widgets on certain pages.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
suecrawfordesign
Thanks, Catrina. That makes sense. But I'm not very proficient at CSS. Could you suggest some code I could try? I would like to hide the widgets on the main posts page.

Share this post


Link to post
Share on other sites
ah2evoxy82raqhs
Thanks SimpleMama! Actually Widget Logic didn't work, but you pointed me in the right direction. The widget that actually does the trick is "Display widgets".

Share this post


Link to post
Share on other sites
suecrawfordesign
Thank you! The "Display Widgets" plugin worked for me as well! I appreciate this online community and all the help!! Sue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×