Jump to content
Sign in to follow this  
xtrme

PlatformPro 2 Main Menu messed up on default page

Recommended Posts

xtrme

Upgraded from 1.5 and main menu on default page displays all pages instead of specified ones. The rest of the pages have the main menu displayed properly. Also, the menu isn't displaying the custom code on any of the pages: #primary-nav .texture { background-color: #d3d3d3; color: #ffffff !important; } .sf-menu li, #primary-nav ul.sf-menu a:focus, .sf-menu a:hover, .sf-menu a:active { background-color: #a58d8d; } .main-nav li.current-page-ancestor a, .main-nav li.current_page_item a, .main-nav li.current-page-ancestor ul a, .main-nav li.current_page_item ul a, .sf-menu li li, .sf-menu li li, .sf-menu li li li { background: none repeat scroll 0 0 #949393; color:#ffffff !important; } .main_nav .main-nav li a:hover, .current_page_item a, .current_page_item ul li a:hover, .sf-menu li:hover, .sf-menu li.sfHover { background: none repeat scroll 0 0 #949393; color: #ffffff !important; }

Share this post


Link to post
Share on other sites
Rob
Please see this. http://www.pagelines.com/forum/discussion/15782/menu-fix-for-2.0-upgrade#Item_1 Let us know if the solution in this link works.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
xtrme
Haven't had the time to experiment with the settings til now. That fixed part of the problem but the css is still not displaying properly for the menu and a lot of other areas on the site. I'm thinking the 2.01 update will fix it but when I try to update through my site, I get an error that my username doesn't exist (even though I'm logged in at the time) I can't find a link for the update on the pagelines site. Please send one.

Share this post


Link to post
Share on other sites
Danny
Hi xtrme, Your custom CSS isn't working as you need to copy it over from Platform Pro Settings > Custom Code > CSS Rules to the PageLines Framework 2.0 Settings > Custom Code > CSS Rules. Also, some of the class, ID names have changed, I have started a post for commonly asked CSS tweaks and will be updating as soon as possible. You can find the post [url=http://www.pagelines.com/forum/discussion/15956/pagelines-framework-2.0-css-tweaks.#Item_1]here[/url]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
xtrme
Hi Danny, That helped a bit but most of it still isn't displaying properly. The "more" text link on the features for instance is white on white with a faint drop shadow even though I have no custom css for the features. Another thing... where are the settings for boxes and features hidden? I'm trying to change the number of boxes per page and to get the features changing on their own again (used to be easy) Can't say I'm liking this much so far.

Share this post


Link to post
Share on other sites
xtrme
Aha! I went back and clicked on "special" and found the settings for boxes and features. Now all I have to do is update all the custom css.

Share this post


Link to post
Share on other sites
xtrme
Cancel the last comment. I don't want to edit "special" pages. I just want the same settings as I used to have. How do I change box and feature settings?

Share this post


Link to post
Share on other sites
Danny
The features and Boxes are now on a per post/page basis, to change them simply go to the post/page you wish to change and scroll down to the PageLines Meta Settings, there you can change the settings for features and boxes.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×